summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--PKGBUILD.tt12
3 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b34f3b7e8b7..c34446231849 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = perl-cache-simple-timedexpiry
pkgdesc = Perl package providing a lightweight cache with timed expiration
pkgver = 0.27
- pkgrel = 1
- url = http://search.cpan.org/dist/Cache-Simple-TimedExpiry
+ pkgrel = 2
+ url = https://metacpan.org/release/Cache-Simple-TimedExpiry
arch = any
license = PerlArtistic
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 25f45dda9e88..b0f5e3f5e6c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,40 @@
# CPAN Name : Cache::Simple::TimedExpiry
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-cache-simple-timedexpiry
pkgver=0.27
-pkgrel=1
+pkgrel=2
pkgdesc='Perl package providing a lightweight cache with timed expiration'
arch=('any')
-url='http://search.cpan.org/dist/Cache-Simple-TimedExpiry'
+url='https://metacpan.org/release/Cache-Simple-TimedExpiry'
license=('PerlArtistic' 'GPL')
depends=('perl')
source=(http://search.cpan.org/CPAN/authors/id/J/JE/JESSE/Cache-Simple-TimedExpiry-0.27.tar.gz)
options=(!emptydirs)
md5sums=('4ef124ab7776f3c257b9ffbed917e67a')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps"
+}
+
build() {
cd Cache-Simple-TimedExpiry-0.27
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd Cache-Simple-TimedExpiry-0.27
+ sanitize
make test
}
package() {
cd Cache-Simple-TimedExpiry-0.27
+ sanitize
make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 57809664b1ba..0677591f20d6 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -14,19 +14,27 @@ source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps"
+}
+
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ sanitize
make test
}
package() {
cd [% distdir %]
+ sanitize
make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}