summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
-rw-r--r--PKGBUILD.tt32
3 files changed, 54 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59ffa2953286..1b34f3b7e8b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = perl-cache-simple-timedexpiry
- pkgdesc = Perl module providing a lightweight cache with timed expiration
+ pkgdesc = Perl package providing a lightweight cache with timed expiration
pkgver = 0.27
pkgrel = 1
- url = http://search.cpan.org/dist/Cache-Simple-TimedExpiry/
+ url = http://search.cpan.org/dist/Cache-Simple-TimedExpiry
arch = any
- license = GPL
license = PerlArtistic
+ license = GPL
depends = perl
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/J/JE/JESSE/Cache-Simple-TimedExpiry-0.27.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 6d127601bce4..25f45dda9e88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
+# CPAN Name : Cache::Simple::TimedExpiry
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
pkgname=perl-cache-simple-timedexpiry
pkgver=0.27
pkgrel=1
-pkgdesc="Perl module providing a lightweight cache with timed expiration"
-arch=("any")
-url="http://search.cpan.org/dist/Cache-Simple-TimedExpiry/"
-license=("GPL" "PerlArtistic")
-depends=("perl")
+pkgdesc='Perl package providing a lightweight cache with timed expiration'
+arch=('any')
+url='http://search.cpan.org/dist/Cache-Simple-TimedExpiry'
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+source=(http://search.cpan.org/CPAN/authors/id/J/JE/JESSE/Cache-Simple-TimedExpiry-0.27.tar.gz)
options=(!emptydirs)
-source=(http://search.cpan.org/CPAN/authors/id/J/JE/JESSE/Cache-Simple-TimedExpiry-$pkgver.tar.gz)
-md5sums=("4ef124ab7776f3c257b9ffbed917e67a")
+md5sums=('4ef124ab7776f3c257b9ffbed917e67a')
build() {
- cd "$srcdir/Cache-Simple-TimedExpiry-$pkgver"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
-}
+ cd Cache-Simple-TimedExpiry-0.27
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
check() {
- cd "$srcdir/Cache-Simple-TimedExpiry-$pkgver"
- make test
+ cd Cache-Simple-TimedExpiry-0.27
+ make test
}
package() {
- cd "$srcdir/Cache-Simple-TimedExpiry-$pkgver"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd Cache-Simple-TimedExpiry-0.27
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..57809664b1ba
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : Cache::Simple::TimedExpiry
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl package providing a lightweight cache with timed expiration'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+source=([% source %])
+options=(!emptydirs)
+md5sums=('[% md5sums %]')
+
+build() {
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd [% distdir %]
+ make test
+}
+
+package() {
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}