summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD11
-rw-r--r--install8
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9abc048348dd..dc0955b022c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,6 @@ pkgbase = perl-convert-uulib
pkgver = 1.4
pkgrel = 3
url = http://search.cpan.org/~mlehmann/Convert-UUlib/
- install = install
arch = any
license = GPL
license = PerlArtistic
diff --git a/PKGBUILD b/PKGBUILD
index 012587037004..28aaaffbe49e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,6 @@ url='http://search.cpan.org/~mlehmann/Convert-UUlib/'
license=('GPL' 'PerlArtistic')
depends=('perl>=5.8.4')
options=(!emptydirs)
-install="install"
source=("http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/Convert-UUlib-${pkgver}.tar.gz")
md5sums=('a6486df1d9ce319406fb9d5a610da759')
@@ -29,6 +28,16 @@ build(){
perl Makefile.PL
make
}
+
+check() {
+ cd "${srcdir}"/"${_dist}"-"${pkgver}"
+
+ unset PERL5LIB PERL_MM_OPT
+ export PERL_MM_USE_DEFAULT=1
+
+ make test
+}
+
package() {
cd "${srcdir}"/"${_dist}"-"${pkgver}"
diff --git a/install b/install
deleted file mode 100644
index 41c5d667b446..000000000000
--- a/install
+++ /dev/null
@@ -1,8 +0,0 @@
-post_install() {
- echo -n "module test... "
- perl -mConvert::UUlib -e "exit 0;" 2> /dev/null && echo 'pass.' || echo 'fail.'
-}
-
-post_upgrade() {
- post_install
-}