summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6110135733ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Dec 16 01:52:35 UTC 2016
+pkgbase = perl-dynaloader-functions
+ pkgdesc = Perl DynaLoader::Functions CPAN module
+ pkgver = 0.002
+ pkgrel = 1
+ url = http://search.cpan.org/dist/DynaLoader-Functions/
+ arch = any
+ license = unknown
+ depends = perl
+ depends = perl-module-build
+ options = !emptydirs
+ source = http://www.cpan.org/authors/id/Z/ZE/ZEFRAM/DynaLoader-Functions-0.002.tar.gz
+ sha256sums = c7335cda1a10eb0249171a6c1f282b0a0ae5366a656292f236a52a309c83b1aa
+
+pkgname = perl-dynaloader-functions
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e03caa3e66a0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+DynaLoader-Functions-*.tar.gz
+perl-dynaloader-functions-*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d0c4fa51cc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yardena Cohen <yardenack at gmail dot com>
+
+cpaname=DynaLoader-Functions
+cpanauthor=ZEFRAM
+pkgname=perl-dynaloader-functions
+pkgver=0.002
+pkgrel=1
+pkgdesc="Perl DynaLoader::Functions CPAN module"
+arch=('any')
+url="http://search.cpan.org/dist/${cpaname}/"
+license=('unknown')
+options=('!emptydirs')
+depends=('perl' 'perl-module-build')
+source=("http://www.cpan.org/authors/id/${cpanauthor::1}/${cpanauthor::2}/${cpanauthor}/${cpaname}-${pkgver}.tar.gz")
+sha256sums=('c7335cda1a10eb0249171a6c1f282b0a0ae5366a656292f236a52a309c83b1aa')
+
+build() {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ make test
+}
+
+package () {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
+}