summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD29
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b32217ee3a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-email-foldertype
+ pkgdesc = Perl module to determine the type of a mail folder
+ pkgver = 0.813
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Email-FolderType/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.8.9
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Email-FolderType-0.813.tar.gz
+ md5sums = 4d33367e38ec1548737c15ccd200f18c
+
+pkgname = perl-email-foldertype
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8faefa809d29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+pkgname=perl-email-foldertype
+pkgver=0.813
+pkgrel=1
+pkgdesc="Perl module to determine the type of a mail folder"
+arch=("any")
+url="http://search.cpan.org/dist/Email-FolderType/"
+license=("GPL" "PerlArtistic")
+depends=("perl>=5.8.9")
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Email-FolderType-$pkgver.tar.gz)
+md5sums=("4d33367e38ec1548737c15ccd200f18c")
+
+build() {
+ cd "$srcdir/Email-FolderType-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/Email-FolderType-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/Email-FolderType-$pkgver"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}