summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d0528568b49..c8742a118d0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = perl-geo-distance
pkgdesc = Geo::Distance - Perl interface to calculate geo distance from latitude and longitude
- pkgver = 0.20
- pkgrel = 3
- url = http://search.cpan.org/~bluefeet/Geo-Distance-0.20/
+ pkgver = 0.25
+ pkgrel = 1
+ url = https://metacpan.org/release/Geo-Distance
arch = i686
arch = x86_64
license = GPL
license = PerlArtistic
+ makedepends = perl-module-build-tiny
depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/B/BL/BLUEFEET/Geo-Distance-0.20.tar.gz
- sha256sums = 514c5b16ea064fa6f3f41d83672477a6dc3b9c31494d9e1b4f084ef750f9c58a
+ source = http://search.cpan.org/CPAN/authors/id/B/BL/BLUEFEET/Geo-Distance-0.25.tar.gz
+ sha256sums = 2c673dd57c86208370da100f75f0482531b05306aa5f72107b0eae90b6ceb615
pkgname = perl-geo-distance
-
diff --git a/PKGBUILD b/PKGBUILD
index da5fe5676376..d7a68af35829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=perl-geo-distance
-pkgver=0.20
-pkgrel=3
+pkgver=0.25
+pkgrel=1
pkgdesc='Geo::Distance - Perl interface to calculate geo distance from latitude and longitude'
arch=('i686' 'x86_64')
-url="http://search.cpan.org/~bluefeet/Geo-Distance-${pkgver}/"
+url='https://metacpan.org/release/Geo-Distance'
license=('GPL' 'PerlArtistic')
depends=('perl')
+makedepends=('perl-module-build-tiny')
options=(!emptydirs)
source=("http://search.cpan.org/CPAN/authors/id/B/BL/BLUEFEET/Geo-Distance-${pkgver}.tar.gz")
-sha256sums=('514c5b16ea064fa6f3f41d83672477a6dc3b9c31494d9e1b4f084ef750f9c58a')
+sha256sums=('2c673dd57c86208370da100f75f0482531b05306aa5f72107b0eae90b6ceb615')
build() {
cd "${srcdir}/Geo-Distance-${pkgver}"
# install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ PERL_MM_USE_DEFAULT=1 perl Build.PL
+ ./Build
}
package() {
cd "${srcdir}/Geo-Distance-${pkgver}"
- make install DESTDIR="${pkgdir}/"
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
# remove perllocal.pod and .packlist
find "${pkgdir}" -name perllocal.pod -delete