summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD58
2 files changed, 45 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 938812b3722c..21d7d7f32227 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = perl-net-netmask
- pkgdesc = Parse, manipulate and lookup IP network blocks.
- pkgver = 2.0001
+ pkgdesc = parse, manipulate and lookup IP network blocks
+ pkgver = 2.0002
pkgrel = 1
url = https://metacpan.org/release/Net-Netmask
arch = any
- license = GPL
license = PerlArtistic
- checkdepends = perl-test-useallmodules
- checkdepends = perl-test2-suite
+ license = GPL
+ checkdepends = perl-test-useallmodules>=0.17
+ checkdepends = perl-test2-suite>=0
+ depends = perl>=5.6.1
options = !emptydirs
- source = http://cpan.metacpan.org/authors/id/J/JM/JMASLAK/Net-Netmask-2.0001.tar.gz
- md5sums = 4185706d6eb978e59b1ab9e89d1865aa
+ source = http://search.cpan.org/CPAN/authors/id/J/JM/JMASLAK/Net-Netmask-2.0002.tar.gz
+ md5sums = a05fe8ca952c1db0acff02cbc6626148
+ sha512sums = 60cd9de1cac95516515428eb7d1c883b5260333768c363b47a87bb404b13bac713746e7512ff1f52bf3e5c8344f0d38889bba44a2c84b8ddf36e969d63ea8373
pkgname = perl-net-netmask
diff --git a/PKGBUILD b/PKGBUILD
index 0130df7b6035..8e28311e40d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,50 @@
-# Maintainer: Brian Bidulock <bidulock@openss7.org>
-# Contributor: Alexander Krylov <kass@tpi.ru>
+# Contributor: CpanBot <cpanbot at sch bme hu>
+# Generator : CPANPLUS::Dist::Arch 1.32
-pkgname=perl-net-netmask
-_cpanname=Net-Netmask
-_module=Net::Netmask
-pkgver=2.0001
-pkgrel=1
-pkgdesc="Parse, manipulate and lookup IP network blocks."
+pkgname='perl-net-netmask'
+pkgver='2.0002'
+pkgrel='1'
+pkgdesc="parse, manipulate and lookup IP network blocks"
arch=('any')
-url="https://metacpan.org/release/$_cpanname"
-license=('GPL' 'PerlArtistic')
-depends=()
-checkdepends=('perl-test-useallmodules' 'perl-test2-suite')
+license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-source=("http://cpan.metacpan.org/authors/id/J/JM/JMASLAK/${_cpanname}-${pkgver}.tar.gz")
-md5sums=('4185706d6eb978e59b1ab9e89d1865aa')
+depends=('perl>=5.6.1')
+makedepends=()
+checkdepends=('perl-test-useallmodules>=0.17' 'perl-test2-suite>=0')
+url='https://metacpan.org/release/Net-Netmask'
+source=('http://search.cpan.org/CPAN/authors/id/J/JM/JMASLAK/Net-Netmask-2.0002.tar.gz')
+md5sums=('a05fe8ca952c1db0acff02cbc6626148')
+sha512sums=('60cd9de1cac95516515428eb7d1c883b5260333768c363b47a87bb404b13bac713746e7512ff1f52bf3e5c8344f0d38889bba44a2c84b8ddf36e969d63ea8373')
+_distdir="Net-Netmask-2.0002"
build() {
- cd $_cpanname-$pkgver
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
}
check() {
- cd $_cpanname-$pkgver
- make test
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
}
package() {
- cd $_cpanname-$pkgver
- make install DESTDIR="$pkgdir"
- find "$pkgdir" \( -name '.packlist' -o -name '*.pod' \) -delete
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
# vim:set ts=2 sw=2 et: