summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--5c18a54935955903ada55096115c347e08118a75.patch26
-rw-r--r--PKGBUILD13
3 files changed, 41 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24605b8a9bd9..47242acecb11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = perl-net-sip
pkgdesc = SIP (Voice Over IP, RFC3261) packet handling
- pkgver = 0.827
- pkgrel = 1
+ pkgver = 0.836
+ pkgrel = 2
url = https://github.com/noxxi/p5-net-sip
arch = any
license = PerlArtistic
depends = perl-net-dns
options = !emptydirs
- source = https://cpan.metacpan.org/authors/id/S/SU/SULLR/Net-SIP-0.827.tar.gz
- sha512sums = 7060840e3eb913100c7facec7b3329a55bfb18d66d89787d61071d3b1fbdc80c038387bcb8bc202440b9c0c31a0006f68a25dc4eed6a608aed85998a995276e7
+ source = https://cpan.metacpan.org/authors/id/S/SU/SULLR/Net-SIP-0.836.tar.gz
+ source = 5c18a54935955903ada55096115c347e08118a75.patch
+ sha512sums = a87096ffaac2c87f252f7d06524398341e5f3a674745fa7a1613aeb087d29edcb933c28fce750b0ce77f54a83a91c6ffea8c95743c97370368c4e83af98da8d9
+ sha512sums = 167074ffc428fc0a92b81779f527e0d7500a22eb97bce3a0bc00b4fd0c242ae01ca7b1a859dffcc61616ba80b5cb7827d0f8695620005ee5f33cedd1db10432d
pkgname = perl-net-sip
-
diff --git a/5c18a54935955903ada55096115c347e08118a75.patch b/5c18a54935955903ada55096115c347e08118a75.patch
new file mode 100644
index 000000000000..1a02b3b84a8a
--- /dev/null
+++ b/5c18a54935955903ada55096115c347e08118a75.patch
@@ -0,0 +1,26 @@
+From 5c18a54935955903ada55096115c347e08118a75 Mon Sep 17 00:00:00 2001
+From: Steffen Ullrich <github@maulwuff.de>
+Date: Tue, 18 Jul 2023 06:55:27 +0200
+Subject: [PATCH] fix exiting subroutine with next in test
+
+---
+ t/19_call_with_dtmf.t | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/t/19_call_with_dtmf.t b/t/19_call_with_dtmf.t
+index 36c4e9d..1468fa6 100644
+--- a/t/19_call_with_dtmf.t
++++ b/t/19_call_with_dtmf.t
+@@ -185,10 +185,10 @@ sub uas {
+ my $diff = ($seq - $lastseq) % 2**32;
+ if ($diff == 0) {
+ diag("duplicate $seq");
+- next;
++ return;
+ } elsif ($diff>2**31) {
+ diag("out of order $seq");
+- next;
++ return;
+ }
+ if ($diff>1) {
+ $lost += $diff-1;
diff --git a/PKGBUILD b/PKGBUILD
index 1efab63b2236..963e9f594726 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Moritz Bunkus <moritz@bunkus.org>
pkgname="perl-net-sip"
-pkgver="0.827"
-pkgrel="1"
+pkgver="0.836"
+pkgrel="2"
pkgdesc="SIP (Voice Over IP, RFC3261) packet handling"
arch=("any")
license=("PerlArtistic")
options=("!emptydirs")
depends=("perl-net-dns")
url="https://github.com/noxxi/p5-net-sip"
-source=("https://cpan.metacpan.org/authors/id/S/SU/SULLR/Net-SIP-${pkgver}.tar.gz")
-sha512sums=('7060840e3eb913100c7facec7b3329a55bfb18d66d89787d61071d3b1fbdc80c038387bcb8bc202440b9c0c31a0006f68a25dc4eed6a608aed85998a995276e7')
+source=("https://cpan.metacpan.org/authors/id/S/SU/SULLR/Net-SIP-${pkgver}.tar.gz"
+ '5c18a54935955903ada55096115c347e08118a75.patch')
+sha512sums=('a87096ffaac2c87f252f7d06524398341e5f3a674745fa7a1613aeb087d29edcb933c28fce750b0ce77f54a83a91c6ffea8c95743c97370368c4e83af98da8d9'
+ '167074ffc428fc0a92b81779f527e0d7500a22eb97bce3a0bc00b4fd0c242ae01ca7b1a859dffcc61616ba80b5cb7827d0f8695620005ee5f33cedd1db10432d')
prepare_environment() {
export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -23,6 +25,9 @@ prepare_environment() {
build() {
prepare_environment
+
+ patch -p1 < "$srcdir/5c18a54935955903ada55096115c347e08118a75.patch"
+
/usr/bin/perl Makefile.PL
make
}