summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD65
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56cf80aab72e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-pod-coverage-trustpod
+ pkgdesc = Pod::Coverage::TrustPod - allow a module's pod to contain Pod::Coverage hints
+ pkgver = 0.100003
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Pod-Coverage-TrustPod/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl-pod-eventual
+ depends = perl-pod-coverage
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Pod-Coverage-TrustPod-0.100003.tar.gz
+ sha256sums = 3f0c42c4656cf22dab0e7c92c9006eb90a4a3068d6950938c4773c5854619ea6
+
+pkgname = perl-pod-coverage-trustpod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8f80e6bd36d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+# Contributor: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+
+pkgname=perl-pod-coverage-trustpod
+pkgver=0.100003
+pkgrel=1
+_author='R/RJ/RJBS'
+_perlmod='Pod-Coverage-TrustPod'
+pkgdesc="Pod::Coverage::TrustPod - allow a module's pod to contain Pod::Coverage hints"
+arch=('any')
+url="http://search.cpan.org/dist/Pod-Coverage-TrustPod/"
+license=('GPL' 'PerlArtistic')
+depends=(
+perl-pod-eventual
+perl-pod-coverage
+)
+provides=()
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('3f0c42c4656cf22dab0e7c92c9006eb90a4a3068d6950938c4773c5854619ea6')
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}