summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
-rw-r--r--PKGBUILD.tt12
3 files changed, 25 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a67466522fe..c98c9d53dd02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = perl-posix-strftime-compiler
pkgdesc = Perl module providing GNU C library compatible strftime for loggers and servers
- pkgver = 0.42
- pkgrel = 2
+ pkgver = 0.44
+ pkgrel = 1
url = https://metacpan.org/release/POSIX-strftime-Compiler
arch = any
license = PerlArtistic
license = GPL
- makedepends = perl-module-build>=0.38
- depends = perl>=5.8.1
+ makedepends = perl-module-build-tiny>=0.035
+ depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/K/KA/KAZEBURO/POSIX-strftime-Compiler-0.42.tar.gz
- md5sums = c0a5f76b1b0ce9cdb90d627b017e6cf5
+ source = http://search.cpan.org/CPAN/authors/id/K/KA/KAZEBURO/POSIX-strftime-Compiler-0.44.tar.gz
+ md5sums = 3a5ae7d56a5917410c1b661e01ed1a68
pkgname = perl-posix-strftime-compiler
diff --git a/PKGBUILD b/PKGBUILD
index 6cd6fad21805..da36632ed9f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-posix-strftime-compiler
-pkgver=0.42
-pkgrel=2
+pkgver=0.44
+pkgrel=1
pkgdesc='Perl module providing GNU C library compatible strftime for loggers and servers'
arch=('any')
url='https://metacpan.org/release/POSIX-strftime-Compiler'
license=('PerlArtistic' 'GPL')
-depends=('perl>=5.8.1')
-makedepends=('perl-module-build>=0.38')
-source=(http://search.cpan.org/CPAN/authors/id/K/KA/KAZEBURO/POSIX-strftime-Compiler-0.42.tar.gz)
+depends=('perl')
+makedepends=('perl-module-build-tiny>=0.035')
+source=(http://search.cpan.org/CPAN/authors/id/K/KA/KAZEBURO/POSIX-strftime-Compiler-0.44.tar.gz)
options=(!emptydirs)
-md5sums=('c0a5f76b1b0ce9cdb90d627b017e6cf5')
+md5sums=('3a5ae7d56a5917410c1b661e01ed1a68')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -21,21 +21,21 @@ sanitize() {
}
build() {
- cd POSIX-strftime-Compiler-0.42
+ cd POSIX-strftime-Compiler-0.44
sanitize
- perl Build.PL --installdirs vendor --destdir "$pkgdir"
- perl Build
+ /usr/bin/perl Build.PL --installdirs vendor --destdir "$pkgdir"
+ /usr/bin/perl Build
}
check() {
- cd POSIX-strftime-Compiler-0.42
+ cd POSIX-strftime-Compiler-0.44
sanitize
- perl Build test
+ /usr/bin/perl Build test
}
package() {
- cd POSIX-strftime-Compiler-0.42
+ cd POSIX-strftime-Compiler-0.44
sanitize
- perl Build install
+ /usr/bin/perl Build install
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 3385bf9f9110..b79606ae188f 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -9,8 +9,8 @@ pkgdesc='Perl module providing GNU C library compatible strftime for loggers and
arch=('any')
url='[% url %]'
license=('PerlArtistic' 'GPL')
-depends=('perl>=5.8.1')
-makedepends=('perl-module-build>=0.38')
+depends=('perl')
+makedepends=('perl-module-build-tiny>=0.035')
source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
@@ -23,19 +23,19 @@ sanitize() {
build() {
cd [% distdir %]
sanitize
- perl Build.PL --installdirs vendor --destdir "$pkgdir"
- perl Build
+ /usr/bin/perl Build.PL --installdirs vendor --destdir "$pkgdir"
+ /usr/bin/perl Build
}
check() {
cd [% distdir %]
sanitize
- perl Build test
+ /usr/bin/perl Build test
}
package() {
cd [% distdir %]
sanitize
- perl Build install
+ /usr/bin/perl Build install
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}