summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD31
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df1434036cbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Dec 16 02:01:09 UTC 2016
+pkgbase = perl-string-approx
+ pkgdesc = Perl String::Approx CPAN module
+ pkgver = 3.27
+ pkgrel = 1
+ url = http://search.cpan.org/dist/String-Approx/
+ arch = any
+ license = unknown
+ depends = perl
+ options = !emptydirs
+ source = http://www.cpan.org/authors/id/J/JH/JHI/String-Approx-3.27.tar.gz
+ sha256sums = 2b8c1acd24fa9681ebba0ccb3c49f16289de1d579af8a0c898ea8f8d1baf5d36
+
+pkgname = perl-string-approx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1cfc5e565f29
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+String-Approx-*.tar.gz
+perl-string-approx-*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e951ba67fe4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yardena Cohen <yardenack at gmail dot com>
+
+cpaname=String-Approx
+cpanauthor=JHI
+pkgname=perl-string-approx
+pkgver=3.27
+pkgrel=1
+pkgdesc="Perl String::Approx CPAN module"
+arch=('any')
+url="http://search.cpan.org/dist/${cpaname}/"
+license=('unknown')
+options=('!emptydirs')
+depends=('perl')
+source=("http://www.cpan.org/authors/id/${cpanauthor::1}/${cpanauthor::2}/${cpanauthor}/${cpaname}-${pkgver}.tar.gz")
+sha256sums=('2b8c1acd24fa9681ebba0ccb3c49f16289de1d579af8a0c898ea8f8d1baf5d36')
+
+build() {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ make test
+}
+
+package () {
+ cd "${srcdir}/${cpaname}-${pkgver}"
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
+}