summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 364b84cb78a6..ac9fb6fa011e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perl-term-size
pkgdesc = provides a straightforward way to get the size of the terminal, or window, on which a script is running
- pkgver = 0.2
- pkgrel = 2
+ pkgver = 0.207
+ pkgrel = 1
url = http://search.cpan.org/dist/Term-Size/
arch = i686
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = perl-term-size
license = PerlArtistic
depends = perl
options = !emptydirs
- source = http://www.cpan.org/authors/id/T/TI/TIMPX/Term-Size-0.2.tar.gz
- md5sums = 982b5df8351e7654a42b7bffc0bf1d57
+ source = http://search.cpan.org/CPAN/authors/id/F/FE/FERREIRA/Term-Size-0.207.tar.gz
+ md5sums = 474438fff3f12fca88a23388cc5a7571
pkgname = perl-term-size
diff --git a/PKGBUILD b/PKGBUILD
index e54adf95fdab..1ab756ca6bed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,31 @@
+# Maintainer: Jens Adam <jra@byte.cx>
# Contributor: Guilherme M. Nogueira <guilherme@nirev.org>
+
+_perlmod=Term-Size
pkgname=perl-term-size
-pkgver=0.2
-pkgrel=2
-pkgdesc="provides a straightforward way to get the size of the terminal, or window, on which a script is running"
-arch=('i686' 'x86_64')
-url="http://search.cpan.org/dist/Term-Size/"
+pkgver=0.207
+pkgrel=1
+pkgdesc='provides a straightforward way to get the size of the terminal, or window, on which a script is running'
+url='http://search.cpan.org/dist/Term-Size/'
license=('GPL' 'PerlArtistic')
+arch=('i686' 'x86_64')
depends=('perl')
options=('!emptydirs')
-source=(http://www.cpan.org/authors/id/T/TI/TIMPX/Term-Size-$pkgver.tar.gz)
-md5sums=('982b5df8351e7654a42b7bffc0bf1d57')
+source=("http://search.cpan.org/CPAN/authors/id/F/FE/FERREIRA/${_perlmod}-${pkgver}.tar.gz")
+md5sums=('474438fff3f12fca88a23388cc5a7571')
build() {
- cd $srcdir/Term-Size-$pkgver
- # Install into vendor directory
- perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd "${srcdir}"/${_perlmod}-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "${srcdir}"/${_perlmod}-${pkgver}
+ make test
}
package() {
- cd $srcdir/Term-Size-$pkgver
- make DESTDIR=$pkgdir install
+ cd "${srcdir}"/${_perlmod}-${pkgver}
+ make DESTDIR="${pkgdir}" install
}