summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7131fef34a2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jun 20 20:59:00 UTC 2017
+pkgbase = perl-test-cchecker
+ pkgdesc = Test::CChecker - Test-time utilities for checking C headers, libraries, or OS features (DEPRECATED)
+ pkgver = 0.08
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Test-CChecker/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ checkdepends = perl-extutils-cchecker
+ makedepends = perl-module-build
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PL/PLICEASE/Test-CChecker-0.08.tar.gz
+ sha256sums = 40cae51024f24854843408c118cdfb5fc1a69c96bf0ea41b5184c8306cfe59e0
+
+pkgname = perl-test-cchecker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15e0839be108
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
+
+pkgname=perl-test-cchecker
+pkgver=0.08
+pkgrel=1
+_author="P/PL/PLICEASE"
+_perlmod="Test-CChecker"
+pkgdesc="Test::CChecker - Test-time utilities for checking C headers, libraries, or OS features (DEPRECATED)"
+arch=('any')
+url="http://search.cpan.org/dist/Test-CChecker/"
+license=('GPL' 'PerlArtistic')
+makedepends=(perl-module-build)
+checkdepends=(perl-extutils-cchecker)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('40cae51024f24854843408c118cdfb5fc1a69c96bf0ea41b5184c8306cfe59e0')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
+ make
+ else
+ perl Build.PL
+ ./Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make test
+ else
+ ./Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+ fi
+}
+