summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD54
2 files changed, 25 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8043dd4caef5..40d5db20ce7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = perl-text-csv-xs
- pkgdesc = comma-separated values manipulation routines
+ pkgdesc = Comma-separated values manipulation routines
pkgver = 1.37
- pkgrel = 1
+ pkgrel = 2
url = https://metacpan.org/release/Text-CSV_XS
- arch = i686
- arch = x86_64
- license = PerlArtistic
+ arch = any
license = GPL
+ license = PerlArtistic
depends = perl
options = !emptydirs
+ options = purge
source = https://cpan.metacpan.org/authors/id/H/HM/HMBRAND/Text-CSV_XS-1.37.tgz
md5sums = 496c20cd1c433fa291733eaed4c0c71e
sha512sums = dfd8ac9d15c42171f4f7bc2b14829dab737a38c1f9fb825ff595775e2767b495e9c2170bb03dd342cafbdb490a18d3962f958fc41699affe2891e5a7f1889557
diff --git a/PKGBUILD b/PKGBUILD
index 7c5fe2369fd7..23b871d39110 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,37 @@
# Maintainer: Amish <contact at via dot aur>
# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
-# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-text-csv-xs
pkgver=1.37
-pkgrel=1
-pkgdesc="comma-separated values manipulation routines"
-arch=('i686' 'x86_64')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
+pkgrel=2
+pkgdesc="Comma-separated values manipulation routines"
+_dist=Text-CSV_XS
+arch=('any')
+url="https://metacpan.org/release/${_dist}"
+license=('GPL' 'PerlArtistic')
depends=('perl')
-makedepends=()
-url='https://metacpan.org/release/Text-CSV_XS'
-source=("https://cpan.metacpan.org/authors/id/H/HM/HMBRAND/Text-CSV_XS-${pkgver}.tgz")
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/H/HM/HMBRAND/${_dist}-${pkgver}.tgz")
md5sums=('496c20cd1c433fa291733eaed4c0c71e')
sha512sums=('dfd8ac9d15c42171f4f7bc2b14829dab737a38c1f9fb825ff595775e2767b495e9c2170bb03dd342cafbdb490a18d3962f958fc41699affe2891e5a7f1889557')
-_distdir="Text-CSV_XS-${pkgver}"
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
}
package() {
- cd "$srcdir/$_distdir"
- make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: