summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95c37285c8ab..09259c9386ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 13 18:23:56 UTC 2016
+# Sat Sep 10 17:52:31 UTC 2016
pkgbase = perl6-linenoise
pkgdesc = Bindings to linenoise
pkgver = 0.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/hoelzro/p6-linenoise
arch = i686
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = perl6-linenoise
makedepends = alacryd
makedepends = git
makedepends = make
+ makedepends = perl6-librarymake
depends = perl6
- depends = perl6-native-resources
source = perl6-linenoise-0.1.0::git+https://github.com/hoelzro/p6-linenoise
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8e4acf9ae73b..6913be3f244f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=perl6-linenoise
pkgver=0.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Bindings to linenoise"
arch=('i686' 'x86_64')
-depends=('perl6' 'perl6-native-resources')
+depends=('perl6')
checkdepends=('perl')
-makedepends=('alacryd' 'git' 'make')
+makedepends=('alacryd' 'git' 'make' 'perl6-librarymake')
groups=('perl6')
url="https://github.com/hoelzro/p6-linenoise"
license=('MIT')
@@ -18,8 +18,15 @@ build() {
cd "$srcdir/$pkgname-$pkgver"
msg2 'Building...'
- perl6 -M Native::Resources::Build \
- -e 'make("$*CWD", "$*CWD/resources/lib", :libname<linenoise>)'
+ mkdir -p blib/lib
+ cat > build.p6 <<'EOF'
+my $workdir = $*CWD;
+my %vars = get-vars("$workdir/blib/lib");
+%vars<helper> = 'resources/libraries/' ~ $*VM.platform-library-name('liblinenoise'.IO);
+process-makefile("$workdir", %vars);
+shell(%vars<MAKE>);
+EOF
+ perl6 -MLibraryMake build.p6
}
check() {
@@ -52,5 +59,7 @@ package() {
msg2 'Cleaning up pkgdir...'
rm -f "$pkgdir/usr/share/perl6/vendor/version"
- find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' +
+ find "$pkgdir" -type f -print0 -exec \
+ sed -i -e "s,$pkgdir,,g" -e "s,$srcdir,,g" '{}' +
}