summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f16798a8bb86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl6-shell-command
+ pkgdesc = Common shell command replacements
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/tadzik/Shell-Command
+ arch = any
+ groups = perl6
+ license = MIT
+ checkdepends = perl
+ makedepends = git
+ depends = rakudo
+ depends = perl6-file-find
+ source = perl6-shell-command-0.0.1::git+https://github.com/tadzik/Shell-Command
+ sha256sums = SKIP
+
+pkgname = perl6-shell-command
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea9db4a04f50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-shell-command
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Common shell command replacements"
+arch=('any')
+depends=('rakudo' 'perl6-file-find')
+checkdepends=('perl')
+makedepends=('git')
+groups=('perl6')
+url="https://github.com/tadzik/Shell-Command"
+license=('MIT')
+source=($pkgname-$pkgver::git+https://github.com/tadzik/Shell-Command)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/share/perl6/vendor/lib"
+ find lib -mindepth 1 -maxdepth 1 -exec \
+ cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/perl6/vendor/lib" \;
+}