summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO62
-rw-r--r--PKGBUILD6
2 files changed, 34 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf38da5f8f6d..43d537c2f8fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,35 @@
pkgbase = petsc
- pkgdesc = Portable, extensible toolkit for scientific computation
- pkgver = 3.12.4
- pkgrel = 2
- url = https://www.mcs.anl.gov/petsc/
- install = petsc.install
- arch = i686
- arch = x86_64
- license = BSD
- makedepends = gcc
- makedepends = gcc-fortran
- makedepends = cmake
- depends = python
- depends = openmpi
- depends = boost
- depends = lapack
- optdepends = trilinos: support for trilinos
- optdepends = ptscotch: support for ptscotch parallel graph partitioning library
- optdepends = parmetis: support for parmetis parallel graph partitioning library
- optdepends = metis: support for metis graph partitioning library
- optdepends = pastix: support for the pastix solver
- optdepends = superlu: support for the superlu sparse solver
- optdepends = hypre: support for the hypre sparse system solver
- optdepends = hdf5: support for the parallel version of hdf5
- optdepends = mumps: support for the mumps sparse solver
- optdepends = fftw: support for the fftw fast Fourier transform
- optdepends = suitesparse: support for the suitesparse sparse matrix libraries
- options = staticlibs
- source = http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-lite-3.12.4.tar.gz
- source = test_optdepends.sh
- sha256sums = 800a965dd01adac099a186588cda68e4fcb224af326d8aaf55978361c019258f
- sha256sums = f127806175b681f4e9cb64aeba4f3fabd9eb92ef945f5542677b255cb3d85913
+ pkgdesc = Portable, extensible toolkit for scientific computation
+ pkgver = 3.13.0
+ pkgrel = 1
+ url = https://www.mcs.anl.gov/petsc/
+ install = petsc.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = gcc
+ makedepends = gcc-fortran
+ makedepends = cmake
+ depends = python
+ depends = openmpi
+ depends = boost
+ depends = lapack
+ optdepends = trilinos: support for trilinos
+ optdepends = ptscotch: support for ptscotch parallel graph partitioning library
+ optdepends = parmetis: support for parmetis parallel graph partitioning library
+ optdepends = metis: support for metis graph partitioning library
+ optdepends = pastix: support for the pastix solver
+ optdepends = superlu: support for the superlu sparse solver
+ optdepends = hypre: support for the hypre sparse system solver
+ optdepends = hdf5: support for the parallel version of hdf5
+ optdepends = mumps: support for the mumps sparse solver
+ optdepends = fftw: support for the fftw fast Fourier transform
+ optdepends = suitesparse: support for the suitesparse sparse matrix libraries
+ options = staticlibs
+ source = http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/petsc-lite-3.13.0.tar.gz
+ source = test_optdepends.sh
+ sha256sums = f0ea543a54145c5d1387e25b121c3fd1b1ca834032c5a33f6f1d929e95bdf0e5
+ sha256sums = f127806175b681f4e9cb64aeba4f3fabd9eb92ef945f5542677b255cb3d85913
pkgname = petsc
diff --git a/PKGBUILD b/PKGBUILD
index a48aadee0997..9b321bd579c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Myles English <myles at rockhead dot biz>
# Contributor: Lucas H. Gabrielli <heitzmann at gmail dot com>
pkgname=petsc
-pkgver=3.12.4
-pkgrel=2
+pkgver=3.13.0
+pkgrel=1
_config=linux-c-opt
# if --with-debugging=yes is set then PETSC_ARCH is automatically set to
#"linux-c-debug" for some things, so the _config should be changed too
@@ -31,7 +31,7 @@ optdepends=('trilinos: support for trilinos'
install=petsc.install
source=(http://ftp.mcs.anl.gov/pub/petsc/release-snapshots/${pkgname}-lite-${pkgver/_/-}.tar.gz
test_optdepends.sh)
-sha256sums=('800a965dd01adac099a186588cda68e4fcb224af326d8aaf55978361c019258f'
+sha256sums=('f0ea543a54145c5d1387e25b121c3fd1b1ca834032c5a33f6f1d929e95bdf0e5'
'f127806175b681f4e9cb64aeba4f3fabd9eb92ef945f5542677b255cb3d85913')
_install_dir=/opt/petsc/${_config}