summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
-rw-r--r--peyote.install13
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bbdcdd9977c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v7
+# Tue Oct 13 21:17:45 UTC 2015
+pkgbase = peyote
+ pkgdesc = Audio player with a Midnight Commander interface
+ pkgver = 0.9.12
+ pkgrel = 2
+ url = http://peyote.sourceforge.net/
+ install = peyote.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = desktop-file-utils
+ depends = gstreamer0.10-python
+ depends = gtk-update-icon-cache
+ depends = mutagen
+ depends = pygtk
+ depends = python2-dbus
+ depends = python2-notify
+ optdepends = rxvt-unicode: default terminal emulator for xpeyote
+ source = http://downloads.sourceforge.net/project/peyote/Linux/peyote_0.9.12.tar.bz2
+ sha256sums = 62180b2ba63b0d99ef27bb7753304c08cf557534f7bab7586dd37fdbe6f9e76f
+
+pkgname = peyote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2089282ba0b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Andrew Trabo <v01d3r@gmail.com>
+
+pkgname=peyote
+pkgver=0.9.12
+pkgrel=2
+pkgdesc="Audio player with a Midnight Commander interface"
+url="http://peyote.sourceforge.net/"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('desktop-file-utils' 'gstreamer0.10-python' 'gtk-update-icon-cache' 'mutagen' 'pygtk' 'python2-dbus' 'python2-notify')
+optdepends=("rxvt-unicode: default terminal emulator for xpeyote")
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/project/peyote/Linux/${pkgname}_$pkgver.tar.bz2)
+sha256sums=('62180b2ba63b0d99ef27bb7753304c08cf557534f7bab7586dd37fdbe6f9e76f')
+
+build() {
+ cd ${pkgname}_$pkgver
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}_$pkgver
+ make DESTDIR="$pkgdir/" install
+}
+
diff --git a/peyote.install b/peyote.install
new file mode 100644
index 000000000000..58ea38ebba03
--- /dev/null
+++ b/peyote.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+