summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b05040a34110
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pfsshell-git
+ pkgdesc = Browse and edit PFS filesystems.
+ pkgver = 28.dce247e
+ pkgrel = 1
+ url = https://github.com/uyjulian/pfsshell
+ arch = i686
+ arch = x86_64
+ makedepends = git
+ makedepends = clang
+ makedepends = gcc
+ makedepends = make
+ source = pfsshell-git::git+https://github.com/erickpires/pfsshell.git
+ md5sums = SKIP
+
+pkgname = pfsshell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d206a4bb44b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Erick Pires pires@erickpires.com
+pkgname=pfsshell-git
+pkgver=28.dce247e
+pkgrel=1
+pkgdesc="Browse and edit PFS filesystems."
+arch=("i686" "x86_64")
+url="https://github.com/uyjulian/pfsshell"
+license=('')
+makedepends=('git' 'clang' 'gcc' 'make')
+source=('pfsshell-git::git+https://github.com/erickpires/pfsshell.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ install -Dm755 pfsshell "$pkgdir/usr/bin/pfsshell"
+}