summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--pg_qualstats-git.install3
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..720dc9cb9c0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pg_qualstats-git
+ pkgdesc = postgresql background worker to capture data
+ pkgver = 05032a0
+ pkgrel = 1
+ url = https://github.com/dalibo/pg_qualstats
+ install = pg_qualstats-git.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = BSD
+ makedepends = git
+ depends = postgresql
+ options = !emptydirs
+ options = !libtool
+ source = git://github.com/dalibo/pg_qualstats.git
+ md5sums = SKIP
+
+pkgname = pg_qualstats-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..886ee2b7f7a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Marco44 (Marc Cousin) <cousinmarc at gmail dot com>
+pkgname=pg_qualstats-git
+_gitname=pg_qualstats
+pkgver=05032a0
+pkgrel=1
+pkgdesc="postgresql background worker to capture data"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/dalibo/pg_qualstats"
+license=('BSD')
+depends=('postgresql')
+builddepends=()
+makedepends=(git)
+options=(!emptydirs !libtool)
+source=('git://github.com/dalibo/pg_qualstats.git')
+md5sums=('SKIP')
+install='pg_qualstats-git.install'
+
+pkgver() {
+ cd $_gitname
+ tag=`git tag | grep REL | tail -1`
+ commit=`git log --format="%h" -n 1`
+ echo "$tag_$commit"
+}
+
+build() {
+ local _gitdir=$srcdir/$_gitname
+ cd $_gitdir
+ git clean -dfx
+ git reset --hard
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname
+ make DESTDIR=$pkgdir install
+}
diff --git a/pg_qualstats-git.install b/pg_qualstats-git.install
new file mode 100644
index 000000000000..1bee89257e7b
--- /dev/null
+++ b/pg_qualstats-git.install
@@ -0,0 +1,3 @@
+post_install(){
+ echo "http://powa.readthedocs.io/en/latest/stats_extensions/pg_qualstats.html"
+}