summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
-rw-r--r--changelog28
-rw-r--r--install11
4 files changed, 56 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d368a214b762..12ac8d5c106e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = pgl
pkgdesc = A privacy oriented firewall application (GUI).
- pkgver = 2.3.0
- pkgrel = 2
+ pkgver = 2.3.1
+ pkgrel = 1
url = http://sourceforge.net/projects/peerguardian/
- install = install
changelog = changelog
arch = i686
arch = x86_64
@@ -19,7 +18,6 @@ pkgbase = pgl
depends = iptables
depends = libnetfilter_queue
depends = qt4
- depends = polkit-qt4
depends = whois
optdepends = unzip: for zipped blocklists
optdepends = p7zip: for 7z blocklists
@@ -34,8 +32,9 @@ pkgbase = pgl
backup = etc/pgl/pglcmd.conf
backup = etc/logrotate.d/pglcmd
backup = etc/logrotate.d/pgld
- source = https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/2.3.0/pgl-2.3.0.tar.gz
- sha1sums = e817f8b16377cafa8f39da125d313231a3a8f149
+ source = https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/2.3.1/pgl-2.3.1.tar.gz
+ source = pglinux-2.3.1_p20171006-fno-common.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch?id=492d6119594d1774685fcd4f40fb5d754c3d77c4
+ sha1sums = a91c0c49cdbf78aa6cc1d93b8ed6843290460520
+ sha1sums = 17b0e89ab5cc9ad9b8ac52823e63f741f5cb6d79
pkgname = pgl
-
diff --git a/PKGBUILD b/PKGBUILD
index f34c3f070d11..a2cc26f4101e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,37 @@
# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
pkgname=pgl
-pkgver=2.3.0
-pkgrel=2
+pkgver=2.3.1
+pkgrel=1
pkgdesc='A privacy oriented firewall application (GUI).'
arch=('i686' 'x86_64')
url='http://sourceforge.net/projects/peerguardian/'
license=('GPL3')
-depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue' 'qt4' 'polkit-qt4' 'whois')
+depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue' 'qt4' 'whois')
optdepends=('unzip: for zipped blocklists'
- 'p7zip: for 7z blocklists'
- 'net-tools: to whitelist local IP addresses'
- 'networkmanager: to whitelist newly started network interfaces'
- 'smtp-forwarder: to send reports'
- 'tcptraceroute: to diagnose connection problems')
+ 'p7zip: for 7z blocklists'
+ 'net-tools: to whitelist local IP addresses'
+ 'networkmanager: to whitelist newly started network interfaces'
+ 'smtp-forwarder: to send reports'
+ 'tcptraceroute: to diagnose connection problems')
makedepends=('zlib')
conflicts=('pgl-cli' 'pgl-git')
backup=('etc/pgl/allow.p2p'
- 'etc/pgl/blocklists.list'
- 'etc/pgl/pglcmd.conf'
- 'etc/logrotate.d/pglcmd'
- 'etc/logrotate.d/pgld')
-install=install
+ 'etc/pgl/blocklists.list'
+ 'etc/pgl/pglcmd.conf'
+ 'etc/logrotate.d/pglcmd'
+ 'etc/logrotate.d/pgld')
changelog=changelog
-source=("https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/$pkgver/$pkgname-$pkgver.tar.gz")
-sha1sums=('e817f8b16377cafa8f39da125d313231a3a8f149')
+source=("https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/$pkgver/$pkgname-$pkgver.tar.gz"
+ "pglinux-2.3.1_p20171006-fno-common.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch?id=492d6119594d1774685fcd4f40fb5d754c3d77c4")
+sha1sums=('a91c0c49cdbf78aa6cc1d93b8ed6843290460520'
+ '17b0e89ab5cc9ad9b8ac52823e63f741f5cb6d79')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < ../pglinux-2.3.1_p20171006-fno-common.patch
+}
build() {
cd "$pkgname-$pkgver"
diff --git a/changelog b/changelog
index 8fd117cea516..75c403d6f1a0 100644
--- a/changelog
+++ b/changelog
@@ -1,3 +1,31 @@
+2016-01-14 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+ * 2.3.1-1:
+ Project Maintenance:
+ - Reorganize git repository at SourceForge.
+ - GPG sign all git tags and the release file, using my
+ moblock-deb maintainer GPG key
+ 2048R/0xBAECD1F7D541FD544C2C37A1EAF9B4E3C0145138.
+ - Refactor copyright notice in every file.
+ Sum up in AUTHORS and debian/copyright.
+ pgl is licensed GPL-3+.
+ Documentation updates.
+ Drop build dependency on polkit (currently unneeded).
+ BUILD: Add init/pgl.gentoo to CLEANFILES.
+ pglcmd:
+ - Some code streamlining.
+ - iptables removal script emergency build: add test if file exists.
+ - old iptables removal script: improve logging.
+ - iptables removal script building: build script before inserting rule.
+ Closes: https://sourceforge.net/p/peerguardian/bugs/331/
+ - Drop old transition code and now obsolete files.
+ - Move the builtin LSB init-functions to a separate file.
+ pgld:
+ - dbus: Reformat and drop commented code.
+ - dbus: Drop extra policy at_console.
+ pglgui:
+ - Enhance desktop file.
+ - Use some unmodified Crystal Project Icons.
+
2015-01-25 Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
* 2.3.0-2:
list all dependencies, including those from the base group.
diff --git a/install b/install
deleted file mode 100644
index e20b93d0a3a1..000000000000
--- a/install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_upgrade() {
- if [ $(vercmp $2 2.2.4-2) -lt 0 ]; then
- echo "# Please reenable pgl.service to activate timer."
- echo "# Then reboot or start pgl-update.timer manually."
- fi
-}
-
-post_remove() {
- # Deletes logs, spool and consolidated blocklists
- rm -rf /var/{log,lib,spool}/pgl/
-} \ No newline at end of file