summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Adapt-to-the-new-cl-ixf-API.patch55
-rw-r--r--PKGBUILD12
3 files changed, 9 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8139e8ecc6d1..3080bfecdd08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 10:45:30 UTC 2016
pkgbase = pgloader
pkgdesc = A data loading tool for PostgreSQL, using the COPY command.
- pkgver = 3.2.2
- pkgrel = 4
+ pkgver = 3.3.0.50
+ pkgrel = 1
url = http://pgloader.io/
arch = x86_64
license = custom:PostgreSQL
@@ -13,9 +15,9 @@ pkgbase = pgloader
makedepends = unzip
depends = freetds
depends = zlib
- source = https://github.com/dimitri/pgloader/archive/v3.2.2.tar.gz
+ source = https://github.com/dimitri/pgloader/archive/v3.3.0.50.tar.gz
source = LICENSE
- sha256sums = 5fe5c115e277a9dd616b1077f89bffdf978bc6983ce62d99af9a218142c39e40
+ sha256sums = c2803c3f7ef642f9cfad0acb849bd154e636e1168866d909eee9bbd7047874d9
sha256sums = b34067e89373e1a47367b454862f43061ad1680542b39b6d95ed29c354473e15
pkgname = pgloader
diff --git a/0001-Adapt-to-the-new-cl-ixf-API.patch b/0001-Adapt-to-the-new-cl-ixf-API.patch
deleted file mode 100644
index bf953dd5b423..000000000000
--- a/0001-Adapt-to-the-new-cl-ixf-API.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From a195ac6dd48cb8235b58a5a95eabb5dfb676d72f Mon Sep 17 00:00:00 2001
-From: Dimitri Fontaine <dim@tapoueh.org>
-Date: Sat, 12 Sep 2015 00:19:02 +0200
-Subject: [PATCH] Adapt to the new cl-ixf API.
-
-This allows fixing bugs in processing the IXF files, which pgloader
-directly benefits from.
----
- src/sources/ixf/ixf-schema.lisp | 9 ++++-----
- src/sources/ixf/ixf.lisp | 12 ++++++------
- 2 files changed, 10 insertions(+), 11 deletions(-)
-
-diff --git a/src/sources/ixf/ixf-schema.lisp b/src/sources/ixf/ixf-schema.lisp
-index 946bce5..5f95db8 100644
---- a/src/sources/ixf/ixf-schema.lisp
-+++ b/src/sources/ixf/ixf-schema.lisp
-@@ -67,8 +67,7 @@
-
- (defun list-all-columns (ixf-stream table-name)
- "Return the list of columns for the given IXF-FILE-NAME."
-- (let ((ixf:*ixf-stream* ixf-stream))
-- (let ((ixf (ixf:read-headers)))
-- (list (cons table-name
-- (coerce (ixf:ixf-table-columns (ixf:ixf-file-table ixf))
-- 'list))))))
-+ (ixf:with-ixf-stream (ixf ixf-stream)
-+ (list (cons table-name
-+ (coerce (ixf:ixf-table-columns (ixf:ixf-file-table ixf))
-+ 'list)))))
-diff --git a/src/sources/ixf/ixf.lisp b/src/sources/ixf/ixf.lisp
-index e481260..8872666 100644
---- a/src/sources/ixf/ixf.lisp
-+++ b/src/sources/ixf/ixf.lisp
-@@ -59,12 +59,12 @@
- "Extract IXF data and call PROCESS-ROW-FN function with a single
- argument (a list of column values) for each row."
- (with-connection (conn (source-db copy-ixf))
-- (let ((ixf:*ixf-stream* (conn-handle conn)))
-- (let ((ixf (ixf:read-headers))
-- (row-fn (lambda (row)
-- (pgstate-incf *state* (target copy-ixf) :read 1)
-- (funcall process-row-fn row))))
-- (ixf:map-data ixf row-fn)))))
-+ (let ((ixf (ixf:make-ixf-file :stream (conn-handle conn)))
-+ (row-fn (lambda (row)
-+ (pgstate-incf *state* (target copy-ixf) :read 1)
-+ (funcall process-row-fn row))))
-+ (ixf:read-headers ixf)
-+ (ixf:map-data ixf row-fn))))
-
- (defmethod copy-to-queue ((ixf copy-ixf) queue)
- "Copy data from IXF file FILENAME into queue DATAQ"
---
-2.5.2
-
diff --git a/PKGBUILD b/PKGBUILD
index c5a544b58b26..47c261e32332 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
pkgname=pgloader
-pkgver=3.2.2
-pkgrel=4
+pkgver=3.3.0.50
+pkgrel=1
pkgdesc='A data loading tool for PostgreSQL, using the COPY command.'
arch=('x86_64')
url="http://pgloader.io/"
@@ -9,15 +9,9 @@ license=('custom:PostgreSQL')
depends=('freetds' 'zlib')
makedepends=('sbcl>=1.1.14' 'make' 'gawk' 'curl' 'sqlite' 'unzip')
source=("https://github.com/dimitri/$pkgname/archive/v$pkgver.tar.gz" 'LICENSE')
-sha256sums=('5fe5c115e277a9dd616b1077f89bffdf978bc6983ce62d99af9a218142c39e40'
+sha256sums=('c2803c3f7ef642f9cfad0acb849bd154e636e1168866d909eee9bbd7047874d9'
'b34067e89373e1a47367b454862f43061ad1680542b39b6d95ed29c354473e15')
-prepare() {
- cd "$pkgname-$pkgver"
-
- patch -p1 < ${srcdir}/../0001-Adapt-to-the-new-cl-ixf-API.patch
-}
-
build() {
cd "$pkgname-$pkgver"