summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e067819a403
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pgrouting-1.x
+ pkgdesc = Adds routing functionality to PostGIS/PostgreSQL
+ pkgver = 1.05
+ pkgrel = 1
+ url = http://pgrouting.postlbs.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake>=2.3
+ makedepends = boost>=1.47
+ depends = postgis
+ depends = gcc-libs
+ source = pgrouting-1.x-git::git+https://github.com/albfan/pgrouting#branch=1.05-archlinux
+ sha1sums = SKIP
+
+pkgname = pgrouting-1.x
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1899591699a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Andre Klitzing <andre () incubo () de>
+# Sebastian Jeworutzki <sebastian.jeworutzki () rub () de>
+
+pkgname=pgrouting-1.x
+pkgver=1.05
+pkgrel=1
+pkgdesc="Adds routing functionality to PostGIS/PostgreSQL"
+arch=('i686' 'x86_64')
+url="http://pgrouting.postlbs.org"
+license=('GPL')
+depends=('postgis' 'gcc-libs')
+makedepends=('cmake>=2.3' 'boost>=1.47')
+source=(${pkgname}-git::git+https://github.com/albfan/pgrouting#branch=1.05-archlinux)
+
+sha1sums=('SKIP')
+
+build() {
+ cd ${pkgname}-git
+ mkdir build
+ cd build
+ # TSP needs package GAUL and DD needs CGAL
+ #cmake .. -DWITH_TSP=ON -DWITH_DD=ON
+ cmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-git/build"
+ make DESTDIR="$pkgdir/" install
+}