summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD67
-rw-r--r--dkms.conf7
-rw-r--r--license.dummypackage.txt3
-rw-r--r--phc-intel.default4
-rw-r--r--phc-intel.install32
-rw-r--r--phc-intel.sh55
-rw-r--r--phc-intel.sleep7
-rw-r--r--phc-intel.system-sleep5
10 files changed, 48 insertions, 176 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 531332d2be89..361038aee7c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,18 @@
pkgbase = phc-intel
- pkgdesc = Frequency driver for Intel CPUs with undervolting feature
- pkgver = 0.3.2.12.24
- pkgrel = 1
- url = http://www.linux-phc.org
- install = phc-intel.install
+ pkgdesc = Meta package that depends on phc intel kernel driver, helper script and initscript.
+ pkgver = 0.3.2
+ pkgrel = 4
+ epoch = 1
+ url = https://gitlab.com/linux-phc/phc-intel
arch = any
- license = GPL
- depends = dkms
+ groups = linux-phc
+ groups = phc-intel
+ license = custom: public domain
+ depends = PHC-INTEL-MODULE
+ depends = phc-intel-scripts
+ depends = PHC-INTEL-INITSCRIPT
provides = linux-phc
- backup = etc/default/phc-intel
- source = phc-intel-pack-rev24.tar.bz2::http://www.linux-phc.org/forum/download/file.php?id=178
- source = phc-intel.default
- source = phc-intel.sh
- source = phc-intel.sleep
- source = phc-intel.system-sleep
- source = dkms.conf
- sha256sums = ffe63afb6b1e1805e82cfc7b69426c98df4df8a2f7d66bc64fc0bb7015926409
- sha256sums = ce08a5a4107be1d5723f1f169d515e67b6c77893f3994fc2d0d2ccf611307ed3
- sha256sums = b526f3e8e66f6495531f13f2e6867d3a07b2ec7a7c3b8aa061f22be1cd6e770f
- sha256sums = 569b85988cb38380fec85c25688b76abc24a46601aa8f58eb24eaebf863eebef
- sha256sums = 2e17c90d7bfae8f5070e46388e95d443188eaa7beb5ffdd418a0da090f2e7557
- sha256sums = 7b44882a96eeb7c79dbb7fe5b1ff8cded68c2b6a374c95bdc5e08c414cfd3549
+ source = license.dummypackage.txt
+ sha256sums = 0e0aeb02347977abaa12efcbd9ccfe4d69b9cdf60868c60eb3dda4f1c38b93cd
pkgname = phc-intel
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 5099302046ad..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,10 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!.SRCINFO
-!dkms.conf
-!phc-intel.system-sleep
-!phc-intel.sleep
-!phc-intel.sh
-!phc-intel.install
-!phc-intel.default \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index f2f43e178b5b..9686bb5be154 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,40 @@
-# Maintainer: fs4000 <matthias_dienstbier[at]yahoo[dot]de>
-# Contributor: trapanator <trap[at]trapanator[dot]com>
-# Contributor: tomprogrammer <Thomas-Bahn[at]gmx[dot]net>
+# Maintainer: dreieck (https://aur.archlinux.org/account/dreieck)
pkgname=phc-intel
-_phcver=0.3.2
-pkgver=$_phcver.12.24
-_realver=pack-rev24
-pkgrel=1
-pkgdesc="Frequency driver for Intel CPUs with undervolting feature"
-url="http://www.linux-phc.org"
+groups=(
+ 'linux-phc'
+ 'phc-intel'
+)
+epoch=1
+pkgver=0.3.2
+pkgrel=4
+pkgdesc="Meta package that depends on phc intel kernel driver, helper script and initscript."
+url="https://gitlab.com/linux-phc/phc-intel"
arch=('any')
-license=('GPL')
-depends=('dkms')
-provides=('linux-phc')
-backup=('etc/default/phc-intel')
-install=phc-intel.install
-source=($pkgname-$_realver.tar.bz2::$url/forum/download/file.php?id=178
- phc-intel.{default,sh,sleep,system-sleep}
- dkms.conf)
-sha256sums=('ffe63afb6b1e1805e82cfc7b69426c98df4df8a2f7d66bc64fc0bb7015926409'
- 'ce08a5a4107be1d5723f1f169d515e67b6c77893f3994fc2d0d2ccf611307ed3'
- 'b526f3e8e66f6495531f13f2e6867d3a07b2ec7a7c3b8aa061f22be1cd6e770f'
- '569b85988cb38380fec85c25688b76abc24a46601aa8f58eb24eaebf863eebef'
- '2e17c90d7bfae8f5070e46388e95d443188eaa7beb5ffdd418a0da090f2e7557'
- '7b44882a96eeb7c79dbb7fe5b1ff8cded68c2b6a374c95bdc5e08c414cfd3549')
+license=('custom: public domain')
+depends=(
+ 'PHC-INTEL-MODULE'
+ 'phc-intel-scripts'
+ 'PHC-INTEL-INITSCRIPT'
+)
+makedepends=()
+optdepends=()
+provides=(
+ 'linux-phc'
+)
+conflicts=()
+source=(
+ 'license.dummypackage.txt'
+)
+sha256sums=(
+ '0e0aeb02347977abaa12efcbd9ccfe4d69b9cdf60868c60eb3dda4f1c38b93cd' # license.dummypackage.txt
+)
-prepare() {
- cd $pkgname-$_realver
- sed -i 's,/sbin/modprobe phc-intel |,/sbin/modprobe phc-intel \&\& /usr/bin/phc-intel set |,' phc-intel.modprobe
+pkgver() {
+ # Set version to be the same as the installed package `PHC-INTEL-MODULE`:
+ pacman -Q PHC-INTEL-MODULE | sort | head -n1 | awk '{print $2}' | awk -F- '{print $1}'
}
package() {
- install -Dm644 dkms.conf "$pkgdir/usr/src/phc-intel-$_phcver/dkms.conf"
- install -Dm644 phc-intel.default "$pkgdir/etc/default/phc-intel"
- install -Dm755 phc-intel.sh "$pkgdir/usr/bin/phc-intel"
- install -Dm755 phc-intel.sleep "$pkgdir/usr/lib/pm-utils/sleep.d/00phc-intel"
- install -Dm755 phc-intel.system-sleep "$pkgdir/usr/lib/systemd/system-sleep/phc-intel"
-
- cd $pkgname-$_realver
- install -Dm644 phc-intel.modprobe "$pkgdir/usr/lib/modprobe.d/phc-intel.conf"
- cp -R inc Makefile "$pkgdir/usr/src/phc-intel-$_phcver/"
+ install -Dvm644 "${srcdir}/license.dummypackage.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.dummypackage.txt"
}
diff --git a/dkms.conf b/dkms.conf
deleted file mode 100644
index db660379ac53..000000000000
--- a/dkms.conf
+++ /dev/null
@@ -1,7 +0,0 @@
-PACKAGE_NAME="phc-intel"
-PACKAGE_VERSION=0.3.2
-AUTOINSTALL="yes"
-
-BUILT_MODULE_NAME[0]="phc-intel"
-DEST_MODULE_LOCATION[0]="/extra"
-MAKE[0]="make KERNELSRC=$kernel_source_dir"
diff --git a/license.dummypackage.txt b/license.dummypackage.txt
new file mode 100644
index 000000000000..0ea65c9ca0bf
--- /dev/null
+++ b/license.dummypackage.txt
@@ -0,0 +1,3 @@
+This is a metapackage.
+
+It is under public domain.
diff --git a/phc-intel.default b/phc-intel.default
deleted file mode 100644
index 4e390e7684a4..000000000000
--- a/phc-intel.default
+++ /dev/null
@@ -1,4 +0,0 @@
-# configuration for phc-intel
-
-# voltage IDs to be set for all CPUs
-VIDS=""
diff --git a/phc-intel.install b/phc-intel.install
deleted file mode 100644
index fb69a8b4a045..000000000000
--- a/phc-intel.install
+++ /dev/null
@@ -1,32 +0,0 @@
-post_install() {
- cat <<-EOF
- You can enter the desired voltage IDs in /etc/default/phc-intel.
- Booting with nophc kernel parameter skips setting of VIDs in case of failure.
- EOF
-}
-
-pre_upgrade() {
- if (( "$(vercmp $2 0.3.2.12.19-2)" < 0 )); then
- cd usr/lib/modules/
- for i in *; do
- if [ -f "$i/extramodules/phc-intel.ko" ]; then
- rm -f "$i/extramodules/phc-intel.ko"
- [ -d "$i/kernel" ] && depmod "$i"
- elif [ -f "$i/phc-intel.ko" ]; then
- rm -f "$i/phc-intel.ko"
- rmdir -p --ignore-fail-on-non-empty "$i"
- elif [ -f "$i/extra/phc-intel.ko" ]; then
- rm -f "$i/extra/phc-intel.ko"
- rmdir -p --ignore-fail-on-non-empty "$i/extra"
- [ -d "$i/kernel" ] && depmod "$i"
- fi
- done
- fi
-}
-
-post_upgrade() {
- if (( "$(vercmp $2 0.3.2.12.19-2)" < 0 )); then
- rm -rf usr/src/phc-intel/
- echo '===> The kernel module gets automatically built by DKMS now.'
- fi
-}
diff --git a/phc-intel.sh b/phc-intel.sh
deleted file mode 100644
index cce4bf96ad91..000000000000
--- a/phc-intel.sh
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/bash -e
-shopt -s nullglob
-
-case "$1" in
-start)
- . /etc/default/phc-intel
- if [ -z "$VIDS" ]; then
- echo '=> Please edit /etc/default/phc-intel'
- exit 1
- fi
- echo ':: Setting PHC VIDs'
- for i in /sys/devices/system/cpu/cpu*/cpufreq/phc_vids; do
- echo $VIDS > "$i"
- done
- ;;
-stop)
- echo ':: Resetting default PHC VIDs'
- for i in /sys/devices/system/cpu/cpu*/cpufreq/phc_vids; do
- cp "${i%vids}default_vids" "$i"
- done
- ;;
-status)
- check_off () {
- for i in /sys/devices/system/cpu/cpu*/cpufreq/phc_vids; do
- [ "$(< "$i")" = "$(< "${i%vids}default_vids")" ] || return;
- done
- }
- check_on () {
- for i in /sys/devices/system/cpu/cpu*/cpufreq/phc_vids; do
- [[ "$(< "$i")" =~ "$VIDS" ]] || return;
- done
- }
- echo -n 'PHC status: '
- . /etc/default/phc-intel
- if check_off; then
- echo 'inactive'
- elif check_on; then
- echo 'active'
- else
- echo 'unknown'
- fi
- ;;
-set)
- . /etc/default/phc-intel
- [ -z "$VIDS" ] && exit
- for i in $(< /proc/cmdline); do
- [ $i = nophc ] && exit
- done
- for i in /sys/devices/system/cpu/cpu*/cpufreq/phc_vids; do
- echo $VIDS > "$i"
- done
- ;;
-*)
- echo "usage: $0 {start|stop|status|set}"
-esac
diff --git a/phc-intel.sleep b/phc-intel.sleep
deleted file mode 100644
index 342b81acf831..000000000000
--- a/phc-intel.sleep
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/bash
-
-case $1 in
- resume|thaw)
- . /usr/bin/phc-intel set
- ;;
-esac
diff --git a/phc-intel.system-sleep b/phc-intel.system-sleep
deleted file mode 100644
index c76ea6aafda0..000000000000
--- a/phc-intel.system-sleep
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/bash
-
-if [ "$1" = post ]; then
- . /usr/bin/phc-intel set
-fi