summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--testing.makefile.patch7
3 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b8929e0d0e9..cb73b99b51cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phc-intel-dkms-testing-git
pkgdesc = Frequency driver for Intel CPUs with undervolting feature. DKMS-based kernel module, testing branch, latest git checkout.
pkgver = 0.4.0.rev44.r52.20230220.f0f42bd
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/linux-phc/phc-intel
arch = any
groups = linux-phc
@@ -18,8 +18,10 @@ pkgbase = phc-intel-dkms-testing-git
conflicts = phc-intel-dkms-testing
conflicts = phc-intel-dkms
source = phc-intel-dkms-testing::git+https://gitlab.com/linux-phc/phc-intel.git
+ source = testing.makefile.patch
source = dkms.conf.in
sha256sums = SKIP
+ sha256sums = 082229d12993de097ed60339dd7b3ba36c9cb3d92abf1722516b2921cc07ebc6
sha256sums = 9162c25d0df436a00d8b45d9e97c24a1f2999f5b8a4f78f2995df15d2d31baa7
pkgname = phc-intel-dkms-testing-git
diff --git a/PKGBUILD b/PKGBUILD
index 6df347b7e68b..b06efb9e9d6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ groups=(
)
pkgver=0.4.0.rev44.r52.20230220.f0f42bd
_phcver="$(awk -F. '{print $1"."$2"."$3}' <<<"${pkgver}")"
-pkgrel=2
+pkgrel=3
pkgdesc="Frequency driver for Intel CPUs with undervolting feature. DKMS-based kernel module, testing branch, latest git checkout."
url="https://gitlab.com/linux-phc/phc-intel"
arch=('any')
@@ -41,10 +41,12 @@ conflicts=(
)
source=(
"${_pkgbase}::git+${url}.git"
- dkms.conf.in
+ 'testing.makefile.patch'
+ 'dkms.conf.in'
)
sha256sums=(
'SKIP'
+ '082229d12993de097ed60339dd7b3ba36c9cb3d92abf1722516b2921cc07ebc6' # testing.makefile.patch
'9162c25d0df436a00d8b45d9e97c24a1f2999f5b8a4f78f2995df15d2d31baa7' # dkms.conf.in
)
@@ -52,7 +54,10 @@ prepare() {
cd "${srcdir}/${_pkgbase}"
## Switch to testing branch:
- make brave
+ #make brave # This will error out if the currently running kernel's headers are not installed -- which is likely after an upgrade.
+ ## Manually change Makefile to testing variant:
+ printf '%s\n' "Patching 'Makefile' to build testing variant ..."
+ patch -N --follow-symlinks -i "${srcdir}/testing.makefile.patch" Makefile
## Generate GIT log
git log > "${srcdir}/git.log"
diff --git a/testing.makefile.patch b/testing.makefile.patch
new file mode 100644
index 000000000000..8a6aa73e350e
--- /dev/null
+++ b/testing.makefile.patch
@@ -0,0 +1,7 @@
+--- Makefile.stable 2023-02-22 12:28:31.669900694 +0100
++++ Makefile.testing 2023-02-22 12:28:38.739900473 +0100
+@@ -3,3 +3,3 @@
+ # If you are brave enough to use a test release, uncomment the next line.
+-#VERSION = 0.4.0
++VERSION = 0.4.0
+