summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD22
-rw-r--r--engine.h.patch10
-rw-r--r--libm.patch30
4 files changed, 31 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bae548c13e9b..73aea5b082c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = phlipple-svn
pkgdesc = A puzzle game which goal is to reduce a 3D shape to a single square. Elimination of squares is done by flipping edges around just like in a cardboard box.
- pkgver = 0.8.6.r10
- pkgrel = 1
+ pkgver = 0.8.6.r15
+ pkgrel = 2
url = http://sourceforge.net/projects/phlipple/
arch = i686
arch = x86_64
- license = GPLv3
+ arch = aarch64
+ license = GPL
+ makedepends = subversion
+ depends = mesa
depends = sdl
depends = sdl_mixer
depends = sdl_image
depends = glew
- depends = libvorbis
provides = phlipple
conflicts = phlipple
source = phlipple::svn://svn.code.sf.net/p/phlipple/code/trunk
- source = libm.patch
- md5sums = SKIP
- md5sums = 3bc553faf4501f016ab0dd03307c4547
+ source = engine.h.patch
+ sha256sums = SKIP
+ sha256sums = a103d6f139bd246c45f2b62e8f5689eceea3af49521071e1a4f1167053a42a52
pkgname = phlipple-svn
-
diff --git a/PKGBUILD b/PKGBUILD
index 8cc4d986ce26..736a79802a9c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
# Contributor: Eric Forgeot < http://esclinux.tk >
pkgname=phlipple-svn
-pkgver=0.8.6.r10
-pkgrel=1
+pkgver=0.8.6.r15
+pkgrel=2
pkgdesc="A puzzle game which goal is to reduce a 3D shape to a single square. Elimination of squares is done by flipping edges around just like in a cardboard box."
-arch=("i686" "x86_64")
+arch=("i686" "x86_64" "aarch64")
url="http://sourceforge.net/projects/phlipple/"
-license=('GPLv3')
-depends=('sdl' 'sdl_mixer' 'sdl_image' 'glew' 'libvorbis')
+license=('GPL')
+depends=('mesa' 'sdl' 'sdl_mixer' 'sdl_image' 'glew')
+makedepends=('subversion')
provides=("phlipple")
conflicts=("phlipple")
source=("phlipple::svn://svn.code.sf.net/p/phlipple/code/trunk"
- 'libm.patch')
-md5sums=('SKIP'
- '3bc553faf4501f016ab0dd03307c4547')
+ 'engine.h.patch')
+sha256sums=('SKIP'
+ 'a103d6f139bd246c45f2b62e8f5689eceea3af49521071e1a4f1167053a42a52')
pkgver() {
cd "$srcdir/${pkgname%-*}"
@@ -25,7 +27,7 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-*}"
- patch -Np1 -i "${srcdir}/libm.patch"
+ patch -Np1 -i "${srcdir}/engine.h.patch"
}
build() {
diff --git a/engine.h.patch b/engine.h.patch
new file mode 100644
index 000000000000..3a7e8d0a2ddc
--- /dev/null
+++ b/engine.h.patch
@@ -0,0 +1,10 @@
+--- a/src/engine.h 2021-07-10 18:55:38.720243486 +0200
++++ b/src/engine.h 2021-07-10 18:56:33.728540660 +0200
+@@ -44,7 +44,6 @@
+
+ #define VERTEX_DRAW_INNER_OFFSET 0.15f
+
+-char debugOutput[1024];
+
+ #include "renderstate.h"
+
diff --git a/libm.patch b/libm.patch
deleted file mode 100644
index 39c6a5f6bb90..000000000000
--- a/libm.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Description: Arch Linux, phlipple-svn (AUR) package.
- This patch obtaied from Debian sources.
- Here is a description from original patch.
- ------------------------------------------
- Link with libm for cos().
- This is fallout from the fact that other libraries in Debian, such as
- libvorbisfile, no longer include their own dependencies in the pkg-config
- output. Until now, phlipple built just fine because -lm was added by
- other libraries; now it has to add it on its own.
- .
- This bug should really be fixed upstream by adding an explicit check for
- cos(3) in configure.ac, something like AC_CHECK_LIB([m], [cos])
- I do intend to do that in a future upload, but IMHO this minimal patch
- ought to be suitable for the Jessie freeze.
-Debian-Bug: https://bugs.debian.org/768741
-Author: Peter Pentchev <roam@ringlet.net>
-Forwarded: not-yet
-Last-Update: 2014-11-10
-
---- a/src/Makefile.in
-+++ b/src/Makefile.in
-@@ -233,7 +233,7 @@
- vertex.h
-
- phlipple_LDFLAGS =
--phlipple_LDADD = $(PHLIPPLE_LIBS) $(GL_LIBS)
-+phlipple_LDADD = $(PHLIPPLE_LIBS) $(GL_LIBS) -lm
- all: all-am
-
- .SUFFIXES: