summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rwxr-xr-xPKGBUILD40
-rw-r--r--libm.patch30
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bae548c13e9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = phlipple-svn
+ pkgdesc = A puzzle game which goal is to reduce a 3D shape to a single square. Elimination of squares is done by flipping edges around just like in a cardboard box.
+ pkgver = 0.8.6.r10
+ pkgrel = 1
+ url = http://sourceforge.net/projects/phlipple/
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = sdl
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = glew
+ depends = libvorbis
+ provides = phlipple
+ conflicts = phlipple
+ source = phlipple::svn://svn.code.sf.net/p/phlipple/code/trunk
+ source = libm.patch
+ md5sums = SKIP
+ md5sums = 3bc553faf4501f016ab0dd03307c4547
+
+pkgname = phlipple-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8cc4d986ce26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+# Contributor: Eric Forgeot < http://esclinux.tk >
+
+pkgname=phlipple-svn
+pkgver=0.8.6.r10
+pkgrel=1
+pkgdesc="A puzzle game which goal is to reduce a 3D shape to a single square. Elimination of squares is done by flipping edges around just like in a cardboard box."
+arch=("i686" "x86_64")
+url="http://sourceforge.net/projects/phlipple/"
+license=('GPLv3')
+depends=('sdl' 'sdl_mixer' 'sdl_image' 'glew' 'libvorbis')
+provides=("phlipple")
+conflicts=("phlipple")
+source=("phlipple::svn://svn.code.sf.net/p/phlipple/code/trunk"
+ 'libm.patch')
+md5sums=('SKIP'
+ '3bc553faf4501f016ab0dd03307c4547')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-*}"
+ local ver="$(svnversion)"
+ conf_ver=`sed -n 's/)$//g;s/^AC_INIT(phlipple, //p' configure.ac`
+ printf "${conf_ver:0:5}.r%s" "${ver//[[:alpha:]]}"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-*}"
+ patch -Np1 -i "${srcdir}/libm.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-*}"
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/libm.patch b/libm.patch
new file mode 100644
index 000000000000..39c6a5f6bb90
--- /dev/null
+++ b/libm.patch
@@ -0,0 +1,30 @@
+Description: Arch Linux, phlipple-svn (AUR) package.
+ This patch obtaied from Debian sources.
+ Here is a description from original patch.
+ ------------------------------------------
+ Link with libm for cos().
+ This is fallout from the fact that other libraries in Debian, such as
+ libvorbisfile, no longer include their own dependencies in the pkg-config
+ output. Until now, phlipple built just fine because -lm was added by
+ other libraries; now it has to add it on its own.
+ .
+ This bug should really be fixed upstream by adding an explicit check for
+ cos(3) in configure.ac, something like AC_CHECK_LIB([m], [cos])
+ I do intend to do that in a future upload, but IMHO this minimal patch
+ ought to be suitable for the Jessie freeze.
+Debian-Bug: https://bugs.debian.org/768741
+Author: Peter Pentchev <roam@ringlet.net>
+Forwarded: not-yet
+Last-Update: 2014-11-10
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -233,7 +233,7 @@
+ vertex.h
+
+ phlipple_LDFLAGS =
+-phlipple_LDADD = $(PHLIPPLE_LIBS) $(GL_LIBS)
++phlipple_LDADD = $(PHLIPPLE_LIBS) $(GL_LIBS) -lm
+ all: all-am
+
+ .SUFFIXES: