summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443b455b3a23..fe3afe4d1bc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phoc-git
pkgdesc = Wayland compositor for phones
- pkgver = r118.d8375ab
+ pkgver = r161.d81666f
pkgrel = 1
url = https://source.puri.sm/Librem5/phoc
arch = i686
@@ -13,20 +13,8 @@ pkgbase = phoc-git
makedepends = git
makedepends = wayland-protocols
makedepends = ctags
- depends = libcap
- depends = systemd
- depends = wayland
- depends = opengl-driver
- depends = libxcb
- depends = xcb-util-errors
- depends = xcb-util-image
- depends = xcb-util-wm
- depends = pixman
- depends = libinput
- depends = libxkbcommon
- depends = libpng
- depends = ffmpeg
depends = glib2
+ depends = wlroots
provides = phoc
conflicts = phoc
source = git+https://source.puri.sm/Librem5/phoc.git
diff --git a/PKGBUILD b/PKGBUILD
index ac5cec5dc884..b87454b5a143 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,13 @@
# Maintainer: Sebastian Krzyszkowiak <dos@dosowisko.net>
pkgname=phoc-git
-pkgver=r118.d8375ab
+pkgver=r161.d81666f
pkgrel=1
pkgdesc="Wayland compositor for phones"
url="https://source.puri.sm/Librem5/phoc"
license=("GPL3")
arch=(i686 x86_64 armv6h armv7h)
-depends=('libcap' 'systemd' 'wayland' 'opengl-driver' 'libxcb'
- 'xcb-util-errors' 'xcb-util-image' 'xcb-util-wm' 'pixman'
- 'libinput' 'libxkbcommon' 'libpng' 'ffmpeg' 'glib2')
+depends=('glib2' 'wlroots')
makedepends=('meson' 'ninja' 'git' 'wayland-protocols' 'ctags')
provides=(phoc)
conflicts=(phoc)
@@ -22,7 +20,7 @@ pkgver() {
}
build() {
- arch-meson phoc build
+ arch-meson phoc build -Dembed-wlroots=disabled -Ddefault_library=shared
ninja -C build
}