summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--phoenix-emu-project20
3 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 559bdc8d0450..83416f8cc50e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = phoenix-emu-project
pkgdesc = An emulator of ColecoVision, Sega Master System, Atari Jaguar and 3DO consoles.
pkgver = 2.8.JAG
- pkgrel = 1
+ pkgrel = 2
url = http://www.arts-union.ru/node/23
arch = x86_64
license = custom
@@ -14,7 +14,7 @@ pkgbase = phoenix-emu-project
source = translation.xml.eng
md5sums = d2cdf18c76afac1b3e58325d58f91272
md5sums = 7f9b5652c512887d7e034cc8c07b2045
- md5sums = 2dda6097a84eadaee848c31fe86001bd
+ md5sums = 4272bb20b1c1d8499bd08839faeaaf55
md5sums = 5acbb45a6a1df36eddc3123273595c12
pkgname = phoenix-emu-project
diff --git a/PKGBUILD b/PKGBUILD
index 8473ae931bf3..818d114fa31a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=phoenix-emu-project
pkgver=2.8.JAG
-pkgrel=1
+pkgrel=2
pkgdesc="An emulator of ColecoVision, Sega Master System, Atari Jaguar and 3DO consoles."
url="http://www.arts-union.ru/node/23"
license=('custom')
@@ -14,7 +14,7 @@ source=("http://www.arts-union.ru/sites/default/files/ph28jag-lin-x64.zip"
translation.xml.eng)
md5sums=('d2cdf18c76afac1b3e58325d58f91272'
'7f9b5652c512887d7e034cc8c07b2045'
- '2dda6097a84eadaee848c31fe86001bd'
+ '4272bb20b1c1d8499bd08839faeaaf55'
'5acbb45a6a1df36eddc3123273595c12')
prepare() {
echo
diff --git a/phoenix-emu-project b/phoenix-emu-project
index 16e0502db272..1dc8af3cbc17 100644
--- a/phoenix-emu-project
+++ b/phoenix-emu-project
@@ -1,19 +1,23 @@
#!/bin/sh
-confdir=$HOME/.config/PhoenixEmuProject
+if [ ! -z $XDG_CONFIG_HOME ]; then
+ confdir=$XDG_CONFIG_HOME/PhoenixEmuProject
+else
+ confdir=$HOME/.config/PhoenixEmuProject
+fi
mkdir -p $confdir
cd $confdir
-if [ ! -s $confdir/scalers ] ; then
- cp -r /opt/phoenix-emu-project/scales $confdir/scales
+if [ ! -d $confdir/scalers ]; then
+ cp -fr /opt/phoenix-emu-project/scales/ $confdir/scales/
fi
-if [ ! -s $confdir/shaders ] ; then
- cp -r /opt/phoenix-emu-project/shaders $confdir/shaders
+if [ ! -d $confdir/shaders ]; then
+ cp -fr /opt/phoenix-emu-project/shaders/ $confdir/shaders/
fi
-if [ ! -s $confdir/skin ] ; then
- cp -r /opt/phoenix-emu-project/skin $confdir/skin
+if [ ! -d $confdir/skin ]; then
+ cp -fr /opt/phoenix-emu-project/skin/ $confdir/skin/
fi
if [[ $LANG != "ru_RU"* ]]; then
- cp /opt/phoenix-emu-project/translation.xml.eng $confdir/translation.xml
+ cp -f /opt/phoenix-emu-project/translation.xml.eng $confdir/translation.xml
fi
/opt/phoenix-emu-project/PhoenixEmuProject