summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore6
-rw-r--r--CMakeLists.txt.patch13
-rw-r--r--PKGBUILD63
-rw-r--r--fix_find_config.patch23
5 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89cce8c5476e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Mon Mar 18 16:20:27 UTC 2019
+pkgbase = phonon-qt4-mplayer-git
+ pkgdesc = Mplayer backend for phonon, the multimedia API of KDE. (Qt4 only) GIT version)
+ pkgver = 20120714.7217499
+ pkgrel = 1
+ url = https://projects.kde.org/projects/unmaintained/phonon-mplayer
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = git
+ depends = mplayer
+ depends = phonon-qt4
+ provides = phonon-qt4-backend
+ provides = phonon-qt4-mplayer
+ conflicts = phonon-qt4-mplayer
+ replaces = phonon-mplayer-git
+ source = git://anongit.kde.org/phonon-mplayer.git
+ source = fix_find_config.patch
+ source = CMakeLists.txt.patch
+ sha256sums = SKIP
+ sha256sums = ee6a0a79b995b4bd5bf086624b89b4467411647e9ddeefcd6e1a81d70b318655
+ sha256sums = fd6379172562065acb670e497ade517015f71829abf65cfd8424fe428e405df3
+
+pkgname = phonon-qt4-mplayer-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..602817cfbcb0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!fix_find_config.patch
+!CMakeLists.txt.patch
diff --git a/CMakeLists.txt.patch b/CMakeLists.txt.patch
new file mode 100644
index 000000000000..ac77d62c79fc
--- /dev/null
+++ b/CMakeLists.txt.patch
@@ -0,0 +1,13 @@
+--- CMakeLists.txt 2013-11-08 00:52:55.390713402 +0100
++++ CMakeLists.txt.orig 2013-11-08 00:53:37.140909984 +0100
+@@ -16,10 +16,6 @@
+ # Includes all wanted definitions for Qt
+ include(${QT_USE_FILE})
+
+-# Remove all Qt modules from include path since there are not needed
+-include(cmake/ReduceQtIncludeDirs.cmake)
+-reduce_qt_include_dirs()
+-
+
+ macro(_SET_FANCY _var _value _comment)
+ if (KDESupport_SOURCE_DIR)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1d12db9ff3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Jekyll Wu <adaptee at gmail dot com>
+# Contributor: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Rick W. Chen <stuffcorpse@archlinux.us>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: Marek Kubica <marek@xivilization.net>
+
+pkgname=phonon-qt4-mplayer-git
+pkgver=20120714.7217499
+pkgrel=1
+pkgdesc="Mplayer backend for phonon, the multimedia API of KDE. (Qt4 only) GIT version)"
+arch=('x86_64')
+url='https://projects.kde.org/projects/unmaintained/phonon-mplayer'
+license=('LGPL')
+depends=('mplayer'
+ 'phonon-qt4'
+ )
+makedepends=('cmake'
+ 'automoc4'
+ 'git'
+ )
+provides=('phonon-qt4-backend'
+ 'phonon-qt4-mplayer'
+ )
+conflicts=('phonon-qt4-mplayer')
+replaces=('phonon-mplayer-git')
+source=('git://anongit.kde.org/phonon-mplayer.git'
+ 'fix_find_config.patch'
+ 'CMakeLists.txt.patch'
+ )
+sha256sums=('SKIP'
+ 'ee6a0a79b995b4bd5bf086624b89b4467411647e9ddeefcd6e1a81d70b318655'
+ 'fd6379172562065acb670e497ade517015f71829abf65cfd8424fe428e405df3'
+ )
+
+pkgver() {
+ cd phonon-mplayer
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ mkdir -p build
+
+ patch -d phonon-mplayer -Np1 -i ../fix_find_config.patch
+ patch -d phonon-mplayer -Np0 -i ../CMakeLists.txt.patch
+}
+
+build() {
+ cd build
+ CXXFLAGS+=" -fPIC"
+ cmake ../phonon-mplayer \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_RPATH=ON
+
+ make
+}
+
+
+package () {
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/fix_find_config.patch b/fix_find_config.patch
new file mode 100644
index 000000000000..145538679e36
--- /dev/null
+++ b/fix_find_config.patch
@@ -0,0 +1,23 @@
+diff -aur phonon-mplayer/mplayer/libmplayer/MPlayerConfig.cpp phonon-mplayer2/mplayer/libmplayer/MPlayerConfig.cpp
+--- phonon-mplayer/mplayer/libmplayer/MPlayerConfig.cpp 2011-11-24 18:06:31.105227140 -0800
++++ phonon-mplayer2/mplayer/libmplayer/MPlayerConfig.cpp 2011-11-24 18:17:02.000000000 -0800
+@@ -73,7 +73,7 @@
+ //Under Windows, config file should be inside a subdirectory named mplayer/mplayer
+ QString defaultMPlayerConfigPath = "mplayer/mplayer/config";
+ #else
+- QString defaultMPlayerConfigPath = "~/.mplayer/config";
++ QString defaultMPlayerConfigPath = QDir::homePath()+"/.mplayer/config";
+ #endif
+
+ return _settings.value("mplayer_config_path", defaultMPlayerConfigPath).toString();
+diff -aur phonon-mplayer/mplayer/libmplayer/MPlayerConfig.h phonon-mplayer2/mplayer/libmplayer/MPlayerConfig.h
+--- phonon-mplayer/mplayer/libmplayer/MPlayerConfig.h 2011-11-24 18:06:31.105227140 -0800
++++ phonon-mplayer2/mplayer/libmplayer/MPlayerConfig.h 2011-11-24 18:18:05.000000000 -0800
+@@ -21,6 +21,7 @@
+
+ #include <QtCore/QString>
+ #include <QtCore/QSettings>
++#include <QtCore/QDir>
+
+ namespace Phonon
+ {