summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed7ced16fd2f..0d6a28bfefbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phoronix-test-suite
pkgdesc = The most comprehensive testing and benchmarking platform available for Linux
- pkgver = 9.0.1
+ pkgver = 9.2.1
pkgrel = 1
url = http://www.phoronix-test-suite.com/
arch = any
@@ -15,8 +15,11 @@ pkgbase = phoronix-test-suite
optdepends = unzip: required for universe-cli test suite
optdepends = mesa-demos: required for universe-cli test suite
optdepends = openmpi: required for universe-cli test suite
- source = phoronix-test-suite-9.0.1.tar.gz::https://github.com/phoronix-test-suite/phoronix-test-suite/archive/v9.0.1.tar.gz
- sha256sums = 66f57eeb12241966cb7ad6594981bfd6ccdb28c4a14325271bec50c810d041db
+ options = !strip
+ source = phoronix-test-suite-9.2.1.tar.gz::https://github.com/phoronix-test-suite/phoronix-test-suite/archive/v9.2.1.tar.gz
+ source = https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/phoronix-test-suite-launcher.patch
+ sha256sums = 28acbcb6c5b8eb27c20329cd1a5ea3f1a27abb69812c4b1eeade4b91c89fc7d8
+ sha256sums = 577326343d0303a59fd469c3f9c9740e756dd59c0660c54363b62d6fd1cee26d
pkgname = phoronix-test-suite
diff --git a/PKGBUILD b/PKGBUILD
index 1cf6ba6abd7f..4dbe142eb1e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Andreas Schönfelder <passtschu at freenet dot de>
pkgname=phoronix-test-suite
-pkgver=9.0.1
+pkgver=9.2.1
pkgrel=1
pkgdesc="The most comprehensive testing and benchmarking platform available for Linux"
arch=(any)
@@ -20,8 +20,16 @@ optdepends=('php-gd'
'unzip: required for universe-cli test suite'
'mesa-demos: required for universe-cli test suite'
'openmpi: required for universe-cli test suite')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/phoronix-test-suite/phoronix-test-suite/archive/v${pkgver}.tar.gz")
-sha256sums=('66f57eeb12241966cb7ad6594981bfd6ccdb28c4a14325271bec50c810d041db')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/phoronix-test-suite/phoronix-test-suite/archive/v${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/phoronix-test-suite-launcher.patch")
+sha256sums=('28acbcb6c5b8eb27c20329cd1a5ea3f1a27abb69812c4b1eeade4b91c89fc7d8'
+ '577326343d0303a59fd469c3f9c9740e756dd59c0660c54363b62d6fd1cee26d')
+options=(!strip)
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch phoronix-test-suite -i "${srcdir}/phoronix-test-suite-launcher.patch"
+}
package() {
cd "$srcdir/$pkgname-$pkgver"
@@ -42,5 +50,8 @@ package() {
install -D "${srcdir}/phoronix-test-suite-${pkgver}"/pts-core/external-test-dependencies/xml/generic-packages.xml \
"${pkgdir}"/usr/share/phoronix-test-suite/pts-core/external-test-dependencies/xml/generic-packages.xml
- sed -e "s/^export PTS_DIR=.*/export PTS_DIR=\/usr\/share\/phoronix-test-suite/g" -i ${pkgdir}/usr/bin/phoronix-test-suite
+ install "${srcdir}/phoronix-test-suite-${pkgver}"/phoronix-test-suite \
+ "${pkgdir}"/usr/bin/phoronix-test-suite
+
+ ln -s /usr/bin/phoronix-test-suite "$pkgdir/usr/bin/pts"
}