summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD21
-rw-r--r--phoronix-test-suite-git.install8
2 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abbade988595..3902066749a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Austin Haedicke <austin.haedicke@gmail.com>
+# Maintainer: Austin Haedicke <ausitn.haedicke@gmail.com>
# <gtbjj on #archlinux irc>
_pkgname=phoronix-test-suite
@@ -9,19 +9,22 @@ pkgdesc="The most comprehensive testing and benchmarking platform available for
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.phoronix-test-suite.com/"
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'python' 'ruby')
+depends=('ruby' 'python')
makedepends=('git')
-optdepends=('php' 'php-gtk' 'php-curl' 'php-gd')
-source=("https://github.com/phoronix-test-suite/phoronix-test-suite.git")
+optdepends=('php')
+install=$pkgname.install
+source=("git://github.com/phoronix-test-suite/phoronix-test-suite.git")
md5sums=('SKIP')
+
pkgver() {
- cd $_pkgname
- git describe --always | sed -e 's|-|.|g'
+ cd $_pkgname
+ git describe --always | sed -e 's|-|.|g'
}
package() {
- cd $srcdir/$_pkgname
- mkdir -p $pkgdir/usr/bin
- ./install-sh ${pkgdir}/usr
+ cd ${srcdir}/$_pkgname
+ mkdir -p ${pkgdir}/usr/bin
+ ./install-sh ${pkgdir}/usr
}
+
diff --git a/phoronix-test-suite-git.install b/phoronix-test-suite-git.install
index dd1b5e4caaff..503509be8d6f 100644
--- a/phoronix-test-suite-git.install
+++ b/phoronix-test-suite-git.install
@@ -1,4 +1,4 @@
-To Complete the Installation:
-
-Update your icons:
- $ xdg-icon-resource forceupdate
+post-install() {
+ gtk-update-icon cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+} \ No newline at end of file