summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--fix-source-path.patch13
3 files changed, 33 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04f28376669d..7314f18031c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phosh
pkgdesc = A pure Wayland shell prototype for GNOME on mobile devices
- pkgver = 0.0.1
+ pkgver = 0.0.2
pkgrel = 1
url = https://source.puri.sm/Librem5/phosh
arch = i686
@@ -19,8 +19,10 @@ pkgbase = phosh
depends = libhandy
depends = wlroots
conflicts = phosh-git
- source = https://source.puri.sm/Librem5/phosh/-/archive/v0.0.1/phosh-v0.0.1.tar.gz
- sha256sums = 841d97b48c146c0c8ecd604d1769cf9715d8609de2e36868d416714d50903d63
+ source = https://source.puri.sm/Librem5/phosh/-/archive/v0.0.2/phosh-v0.0.2.tar.gz
+ source = fix-source-path.patch
+ sha256sums = 55d5d08fae1c0ccc326cb5dd761516862622faa920ad2b9a0ed3a250e741526e
+ sha256sums = 4ef6958f314f903e8f86b7410a93927b039342383d83ac9d2704c28e4bb93828
pkgname = phosh
diff --git a/PKGBUILD b/PKGBUILD
index 3305a34fb343..4f8057c1af71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=phosh
-pkgver=0.0.1
+pkgver=0.0.2
pkgrel=1
pkgdesc="A pure Wayland shell prototype for GNOME on mobile devices"
url="https://source.puri.sm/Librem5/phosh"
@@ -18,15 +18,26 @@ makedepends=(git
pkg-config
meson)
conflicts=(phosh-git)
-source=("https://source.puri.sm/Librem5/phosh/-/archive/v${pkgver}/phosh-v${pkgver}.tar.gz")
-sha256sums=('841d97b48c146c0c8ecd604d1769cf9715d8609de2e36868d416714d50903d63')
+source=("https://source.puri.sm/Librem5/phosh/-/archive/v${pkgver}/phosh-v${pkgver}.tar.gz"
+ "fix-source-path.patch")
+sha256sums=('55d5d08fae1c0ccc326cb5dd761516862622faa920ad2b9a0ed3a250e741526e'
+ '4ef6958f314f903e8f86b7410a93927b039342383d83ac9d2704c28e4bb93828')
+
+prepare() {
+ cd phosh-v${pkgver}
+ patch -p1 < ../fix-source-path.patch
+}
build() {
rm -rf build
- arch-meson phosh-v${pkgver} build -Dtests=false
+ arch-meson phosh-v${pkgver} build
ninja -C build
}
+check() {
+ ninja -C build test
+}
+
package() {
DESTDIR="${pkgdir}" ninja -C build install
}
diff --git a/fix-source-path.patch b/fix-source-path.patch
new file mode 100644
index 000000000000..5582784b5cfd
--- /dev/null
+++ b/fix-source-path.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/meson.build b/tests/meson.build
+index f77b29e9d0e65f6db8314cee0e3f760889ea287b..ba764aef8d5b2f47dfdde46226fd7b58558903a5 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -12,7 +12,7 @@ test_env = [
+
+ test_cflags = [
+ '-fPIE',
+- '-I../src',
++ '-I@0@/../src'.format(meson.current_source_dir()),
+ '-I@0@/../src'.format(meson.current_build_dir()),
+ '-I@0@/../src/dbus'.format(meson.current_build_dir()),
+ '-DTEST_DATA_DIR="@0@/data"'.format(meson.current_source_dir()), \ No newline at end of file