summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--photivo.install19
3 files changed, 12 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ca66862982f..6778a10a61b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
+# Generated by mksrcinfo v8
+# Wed May 25 21:13:53 UTC 2016
pkgbase = photivo-hg
pkgdesc = Free and open source photo processor
- pkgver = 1113.66a8c1082d88
+ pkgver = 1117.5d7d1cc4ef4d
pkgrel = 1
url = http://photivo.org/
- install = photivo.install
arch = i686
arch = x86_64
license = GPL3
@@ -21,7 +22,7 @@ pkgbase = photivo-hg
optdepends = python2: Gimp to Photivo plugin
provides = photivo
conflicts = photivo
- source = hg+https://code.google.com/p/photivo/
+ source = hg+https://bitbucket.org/Photivo/photivo
md5sums = SKIP
pkgname = photivo-hg
diff --git a/PKGBUILD b/PKGBUILD
index cecf40fa4231..7818c59ad41c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lukas Jirkovsky <l.jirkovsky AT gmail.com>
pkgname=photivo-hg
-pkgver=1113.66a8c1082d88
+pkgver=1117.5d7d1cc4ef4d
pkgrel=1
pkgdesc="Free and open source photo processor"
arch=('i686' 'x86_64')
@@ -11,8 +11,7 @@ optdepends=('gimp: Gimp plugins' 'python2: Gimp to Photivo plugin')
makedepends=('mercurial' 'gimp')
provides=('photivo')
conflicts=('photivo')
-install=photivo.install
-source=('hg+https://code.google.com/p/photivo/')
+source=('hg+https://bitbucket.org/Photivo/photivo')
md5sums=('SKIP')
pkgver() {
@@ -23,21 +22,24 @@ pkgver() {
prepare() {
cd "$srcdir/photivo"
- # fix the "Gimp to Photivo" plugin
- sed -i -e 's|\x0D$||' -e 's|#!.*|#!/usr/bin/python2|' "mm extern photivo.py"
+ # pull build fixes
+ hg pull -u https://stativ@bitbucket.org/stativ/photivo
}
build() {
cd "$srcdir/photivo"
export INCLUDEPATHS="/usr/include/lensfun"
- qmake-qt4 PREFIX=/usr CONFIG+=WithGimp
+ qmake-qt4 PREFIX=/usr CONFIG-=debug CONFIG+=WithGimp
make
}
package() {
cd "$srcdir/photivo"
+ # do not install local the shortcut to the home
+ sed '/^install:/ s|install_shortcut2 ||' -i Makefile
+
make INSTALL_ROOT="$pkgdir" install
rm -rf "$pkgdir"/home
diff --git a/photivo.install b/photivo.install
deleted file mode 100644
index a742032e8fc0..000000000000
--- a/photivo.install
+++ /dev/null
@@ -1,19 +0,0 @@
-
-post_install() {
- echo "updating desktop mime database..."
- update-desktop-database -q
- update-mime-database usr/share/mime > /dev/null 2>&1
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
-
-op=$1
-shift
-$op $*
-# vim: ft=sh