summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32b7b5ff8630..117b741b4053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
# Generated by mksrcinfo v8
-# Wed Dec 27 22:33:16 UTC 2017
+# Fri Apr 26 17:28:46 UTC 2019
pkgbase = photoname
pkgdesc = Rename JPEG photo files based on shoot date
- pkgver = 3.3
+ pkgver = 4.1
pkgrel = 1
url = https://github.com/dino-/photoname
arch = x86_64
- license = BSD3
- depends = gmp
- depends = libexif
- depends = libffi
- source = https://github.com/dino-/photoname/releases/download/3.3/photoname-3.3-linux.tar.gz
- sha256sums = e6651cc9f3037ea5c34183a176b2199229c2f6b6023e3ebffe71d3ab6fd4bd4f
+ license = ISC
+ options = !strip
+ source = https://github.com/dino-/photoname/releases/download/4.1/photoname-4.1-.AppImage
+ sha256sums = a736b408be90de1a2b3ea37987bcf52ba787921043bebfd17d5bd3678efb2c2f
pkgname = photoname
diff --git a/PKGBUILD b/PKGBUILD
index ad8531079b68..ab37fbc08d65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Dino Morelli <dino@ui3.info>
pkgname=photoname
-pkgver=3.3
+pkgver=4.1
pkgrel=1
pkgdesc='Rename JPEG photo files based on shoot date'
arch=('x86_64')
url="https://github.com/dino-/photoname"
-license=('BSD3')
-depends=('gmp' 'libexif')
+license=('ISC')
+depends=()
makedepends=()
-source=("https://github.com/dino-/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-linux.tar.gz")
+# This software comes as an AppImage, auto-stripping by the AUR tools breaks it
+options=(!strip)
+source=("https://github.com/dino-/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-${CARCH}.AppImage")
-sha256sums=('e6651cc9f3037ea5c34183a176b2199229c2f6b6023e3ebffe71d3ab6fd4bd4f')
+sha256sums=('a736b408be90de1a2b3ea37987bcf52ba787921043bebfd17d5bd3678efb2c2f')
# PKGBUILD functions
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- mkdir "${pkgdir}/usr"
- cp -r * "${pkgdir}/usr"
+ install -m 755 -D "${pkgname}-${pkgver}-${CARCH}.AppImage" "${pkgdir}/usr/bin/${pkgname}"
}