summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD13
2 files changed, 8 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 790d218afffa..2b2c21cbbe10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = photoqt
pkgdesc = Fast and highly configurable image viewer with a simple and nice interface.
- pkgver = 3.2
- pkgrel = 2
+ pkgver = 3.3
+ pkgrel = 1
url = http://photoqt.org/
arch = x86_64
license = GPL2
@@ -24,9 +24,7 @@ pkgbase = photoqt
depends = mpv
optdepends = libqpsd-git: PSB/PSD support
optdepends = xcftools: XCF support
- source = https://photoqt.org/downloads/source/photoqt-3.2.tar.gz
- source = exiv2_0.28.patch
- sha256sums = 96417137f1e9d6cd01a22dbe1b5be27a673c317250cb1cb1a6161f0ee1c317c8
- sha256sums = 57d55dfef69e415e01d6d2c5f5a20b6c07d2a593715057ece68988887f2a2873
+ source = https://photoqt.org/downloads/source/photoqt-3.3.tar.gz
+ sha256sums = 003f94c30fed99746202499eb87041a25944e98f4bedcf9f07cf3600b56d4974
pkgname = photoqt
diff --git a/PKGBUILD b/PKGBUILD
index b9a0d2cad7cd..1717d2df4988 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
pkgname=photoqt
-pkgver=3.2
-pkgrel=2
+pkgver=3.3
+pkgrel=1
pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
arch=('x86_64')
url="http://photoqt.org/"
@@ -14,10 +14,8 @@ depends=('exiv2' 'imagemagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg' 'qt
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules')
-source=(https://photoqt.org/downloads/source/$pkgname-$pkgver.tar.gz
- exiv2_0.28.patch)
-sha256sums=('96417137f1e9d6cd01a22dbe1b5be27a673c317250cb1cb1a6161f0ee1c317c8'
- '57d55dfef69e415e01d6d2c5f5a20b6c07d2a593715057ece68988887f2a2873')
+source=(https://photoqt.org/downloads/source/$pkgname-$pkgver.tar.gz)
+sha256sums=('003f94c30fed99746202499eb87041a25944e98f4bedcf9f07cf3600b56d4974')
prepare() {
cd $srcdir/$pkgname-$pkgver
@@ -27,9 +25,6 @@ prepare() {
# to use GraphicsMagick instead of ImageMagick add: -DIMAGEMAGICK=OFF -DGRAPHICSMAGICK=ON
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF -DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF -DLIBVIPS=OFF -DVIDEO_MPV=ON -DCHROMECAST=OFF
- # PhotoQt v3.2 does not work as-is with exiv2 v0.28
- patch -p0 < ../exiv2_0.28.patch
-
}
build() {