summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD11
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e94dc191d252..48f61390cdf8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = photoqt
pkgdesc = Fast and highly configurable image viewer with a simple and nice interface.
- pkgver = 1.7.1
- pkgrel = 17
+ pkgver = 2.0
+ pkgrel = 1
url = http://photoqt.org/
arch = x86_64
license = GPL2
@@ -21,10 +21,8 @@ pkgbase = photoqt
depends = kimageformats
optdepends = libqpsd-git: PSB/PSD support
optdepends = xcftools: XCF support
- source = http://photoqt.org/pkgs/photoqt-1.7.1.tar.gz
- source = https://gitlab.com/luspi/photoqt/commit/c6fd41478e818f3a651d40f96cab3d790e1c09a4.diff
- md5sums = 656fee6f9923499992f069496a0aaa5d
- md5sums = SKIP
+ source = http://photoqt.org/pkgs/photoqt-2.0.tar.gz
+ sha256sums = a92889c768277d7cec99a1cb175d6e205b94e8ddbf5ff5e98a6c2f07e68ed438
pkgname = photoqt
diff --git a/PKGBUILD b/PKGBUILD
index c9b7beb047dc..20ffafc73b3a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
pkgname=photoqt
-pkgver=1.7.1
-pkgrel=17
+pkgver=2.0
+pkgrel=1
pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
arch=('x86_64')
url="http://photoqt.org/"
@@ -13,15 +13,12 @@ depends=('exiv2' 'graphicsmagick' 'qt5-imageformats' 'qt5-multimedia' 'qt5-svg'
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support')
makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules')
-source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz
- https://gitlab.com/luspi/photoqt/commit/c6fd41478e818f3a651d40f96cab3d790e1c09a4.diff)
-md5sums=('656fee6f9923499992f069496a0aaa5d' 'SKIP')
+source=(http://photoqt.org/pkgs/$pkgname-$pkgver.tar.gz)
+sha256sums=('a92889c768277d7cec99a1cb175d6e205b94e8ddbf5ff5e98a6c2f07e68ed438')
prepare() {
cd $srcdir/$pkgname-$pkgver
- patch -p1 < ../c6fd41478e818f3a651d40f96cab3d790e1c09a4.diff
-
# To build PhotoQt with less features, add -Dxxxx=OFF to
# the next line (where xxxx is the respective CMake option).
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF