summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD57
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42f5d68a373a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = php-phing-bin
+ pkgdesc = PHP project build system based on Apache Ant
+ pkgver = 2.12.0
+ pkgrel = 1
+ url = https://www.phing.info/
+ arch = any
+ license = LGPL
+ depends = php
+ provides = phing=2.12.0
+ provides = php-phing=2.12.0
+ conflicts = phing
+ conflicts = php-phing
+ options = !strip
+ source = https://www.phing.info//get/phing-2.12.0.phar
+ sha256sums = af39b2032a62cc3b40a94bb64f480bdbff1ec913bbb9232dc911a66b7b7d9f54
+
+pkgname = php-phing-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..789fa365593d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# From AUR phing
+# Contributor: Benjamin A. Shelton <zancarius@gmail.com>
+# Source: https://github.com/zancarius/archlinux-pkgbuilds
+
+# I couldn't get AUR phing to work. php_basedir error. I fixed that and came up with a better way to enable extension phar without enabling it systemwide.
+
+set -u
+_pkgname='phing'
+pkgname="php-${_pkgname}-bin"
+pkgver='2.12.0'
+pkgrel='1'
+pkgdesc='PHP project build system based on Apache Ant'
+arch=('any')
+#url='http://pear.phing.info'
+#url='https://github.com/phingofficial/phing'
+url='https://www.phing.info/'
+license=('LGPL')
+depends=('php')
+provides=("${_pkgname}=${pkgver}" "php-${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}" "php-${_pkgname}")
+options=('!strip')
+_verwatch=('http://pear.phing.info/feed.xml' '\s\+<title>phing \([0-9\.]\+\) (stable)</title>.*' 'f')
+source=("${url}/get/${_pkgname}-${pkgver}.phar")
+sha256sums=('af39b2032a62cc3b40a94bb64f480bdbff1ec913bbb9232dc911a66b7b7d9f54')
+
+package() {
+ set -u
+ # While it's rude to enable phar.so systemwide, it's necessary because phing calls many things that use phar.
+ # However it's not necessary because phing calls many other things that require other modules. You must provide for those so provide for phar too.
+ #install -Dpm0644 <(echo $'extension=phar.so') "${pkgdir}/etc/php/conf.d/phar.ini"
+ install -Dpm0755 "${srcdir}/${_pkgname}-${pkgver}.phar" "${pkgdir}/usr/bin/${_pkgname}.phar"
+
+ # Command line launchers
+ local _phing="#!/usr/bin/bash
+# Installed by ${_pkgname}-${pkgver} PKGBUILD from Arch Linux AUR
+# http://aur.archlinux.org/
+%1
+php -d 'open_basedir=NULL' -d 'phar.readonly=0' -d 'extension=phar.so' %2 \\
+ '/usr/bin/${_pkgname}.phar' \"\$@\"
+"
+
+ local _phing1="${_phing//%1/}" # Almost as much trouble as The Cat in the Hat Thing1 and Thing2
+ _phing1="${_phing1// %2/}"
+
+ local _cr=$'\n'
+ local _phing2="${_phing//%1/extracmd=\"\$1\"${_cr}shift}"
+ _phing2="${_phing2// %2/ \$\{extracmd\}}"
+
+ # Command line launchers
+ install -d "${pkgdir}/usr/bin/"
+ echo "${_phing1}" > "${pkgdir}/usr/bin/${_pkgname}"; chmod 755 "${pkgdir}/usr/bin/${_pkgname}"
+ echo "${_phing2}" > "${pkgdir}/usr/bin/${_pkgname}.sh"; chmod 755 "${pkgdir}/usr/bin/${_pkgname}.sh"
+
+ set +u
+}
+set +u