aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--Dockerfile10
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
-rw-r--r--README.md27
-rw-r--r--fig.yml4
-rw-r--r--php-wddx.install13
8 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c55adf35a0cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = php-wddx
+ pkgdesc = PHP extension for wddx
+ pkgver = 5.6.6
+ pkgrel = 2
+ url = http://www.php.net/wddx
+ install = php-wddx.install
+ arch = i686
+ arch = x86_64
+ license = PHP
+ depends = php
+ backup = etc/php/conf.d/wddx.ini
+ source = http://www.php.net/distributions/php-5.6.6.tar.gz
+ md5sums = 2baddcf979a0d4eb65434c4da3bd9cd3
+
+pkgname = php-wddx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f551d2ff79e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/php-*.tar.gz
+/php-*.tar.gz.asc
+/php-wddx-*.pkg.tar.xz
+/php-wddx-*.src.tar.gz
+/pkg/
+/src/
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000000..cb47ee031be6
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,10 @@
+FROM nubs/arch-build
+
+MAINTAINER Spencer Rinehart <anubis@overthemonkey.com>
+
+USER root
+
+RUN pacman --sync --refresh --noconfirm --noprogressbar --quiet
+RUN pacman --sync --noconfirm --noprogressbar --quiet php
+
+USER build
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8fb49f589d7c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Spencer Rinehart
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f064523c2b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Spencer Rinehart <anubis@overthemonkey.com>
+
+_extname=wddx
+pkgname=("php-${_extname}")
+pkgver=5.6.6
+pkgrel=2
+pkgdesc="PHP extension for wddx"
+arch=('i686' 'x86_64')
+url='http://www.php.net/wddx'
+license=('PHP')
+depends=('php')
+backup=("etc/php/conf.d/${_extname}.ini")
+install="php-${_extname}.install"
+source=("http://www.php.net/distributions/php-${pkgver}.tar.gz")
+md5sums=('2baddcf979a0d4eb65434c4da3bd9cd3')
+
+build() {
+ cd "php-${pkgver}/ext/${_extname}"
+
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "php-${pkgver}/ext/${_extname}"
+
+ make INSTALL_ROOT="${pkgdir}" install
+ echo "extension=${_extname}.so" > "${_extname}.ini"
+ install -D -m644 "${_extname}.ini" "${pkgdir}/etc/php/conf.d/${_extname}.ini"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..1abc4e0ea1c8
--- /dev/null
+++ b/README.md
@@ -0,0 +1,27 @@
+# php-wddx-aur
+An [AUR] package build for PHP's [wddx] extension.
+
+## Building
+You can of course build this package using [makepkg], but the recommended way
+of building this package is using [Docker]. This can be done like so:
+
+```bash
+docker build --tag php-wddx-aur .
+docker run --rm --volume "$(pwd):/package" php-wddx-aur
+```
+
+Alternatively, using [Fig]:
+
+```bash
+fig run build
+```
+
+This will start create a docker image tagged as php-wddx-aur and build the
+package inside the container. As a result you should get the built package in
+your current directory.
+
+[AUR]: https://aur.archlinux.org/
+[wddx]: http://php.net/wddx
+[makepkg]: https://wiki.archlinux.org/index.php/Makepkg
+[Docker]: https://www.docker.com/
+[Fig]: http://www.fig.sh/
diff --git a/fig.yml b/fig.yml
new file mode 100644
index 000000000000..b11c60fa7962
--- /dev/null
+++ b/fig.yml
@@ -0,0 +1,4 @@
+build:
+ build: .
+ volumes:
+ - ".:/package"
diff --git a/php-wddx.install b/php-wddx.install
new file mode 100644
index 000000000000..a6674ee4e849
--- /dev/null
+++ b/php-wddx.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo '
+ ==> PHP extension
+
+ A config file was stored under /etc/php/conf.d/ with the extension enabled.
+ '
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: