summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD42
2 files changed, 29 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a5425443f4f..cb66b79ac065 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,17 +2,17 @@
# Tue Dec 12 00:23:56 UTC 2019
pkgbase = php-xapian
pkgdesc = PHP bindings for Xapian
- pkgver = 1.4.14
- pkgrel = 2
+ pkgver = 1.4.18
+ pkgrel = 4
epoch = 1
url = http://xapian.org/docs/bindings/php/
arch = armv7h
arch = i686
arch = x86_64
license = GPL
- depends = php
- depends = xapian-core=1:1.4.14
- source = http://oligarchy.co.uk/xapian/1.4.14/xapian-bindings-1.4.14.tar.xz
+ depends = php7
+ depends = xapian-core
+ source = http://oligarchy.co.uk/xapian/1.4.18/xapian-bindings-1.4.18.tar.xz
sha512sums = SKIP
pkgname = php-xapian
diff --git a/PKGBUILD b/PKGBUILD
index e99b41aecc26..8291bcafc251 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,39 @@
# Maintainer: MartiMcFly <martimcfly [at] autorisation.de>
-# Last Version: curl -s 'https://oligarchy.co.uk/xapian/?C=M;O=D' | grep -oh '>[0-9]*\.[0-9]*\.[0-9]*\/<' | grep -oh '[0-9]*\.[0-9]*\.[0-9]*' | head -n 1
+# Last Version: curl -s 'https://oligarchy.co.uk/xapian/?C=M;O=D' | grep -oh '>[0-9]*\.[0-9]*\.[0-9]*\/<' | grep -oh '[0-9]*\.[0-9]*\.[0-9]*' | head -n 1
-pkgbase=php-xapian
-pkgname=('php-xapian')
-_realname=xapian-bindings
-pkgver=1.4.14
+pkgname=php-xapian
+pkgver="$(curl -s 'https://oligarchy.co.uk/xapian/?C=N;O=D' | grep -oh '>[0-9]*\.[0-9]*\.[0-9]*\/<' | grep -oh '[0-9]*\.[0-9]*\.[0-9]*' | head -n 1)"
epoch=1
pkgrel=2
pkgdesc="PHP bindings for Xapian"
-arch=('armv7h' 'i686' 'x86_64')
+arch=(
+ 'armv7h'
+ 'i686'
+ 'x86_64'
+ )
url="http://xapian.org/docs/bindings/php/"
-depends=('php' "xapian-core=$epoch:$pkgver")
-license=('GPL')
-source=("http://oligarchy.co.uk/xapian/${pkgver}/${_realname}-${pkgver}.tar.xz")
-sha512sums=('SKIP')
+depends=(
+ 'php7'
+ 'xapian-core'
+ )
+license=(
+ 'GPL'
+ )
-pkgver() {
- # Arch implements the latest release, for this reason the version has to be up to date!
- curl -s 'https://oligarchy.co.uk/xapian/?C=N;O=D' | grep -oh '>[0-9]*\.[0-9]*\.[0-9]*\/<' | grep -oh '[0-9]*\.[0-9]*\.[0-9]*' | head -n 1
-}
+_fileName="xapian-bindings-${pkgver}"
+source=("http://oligarchy.co.uk/xapian/${pkgver}/${_fileName}.tar.xz")
+sha512sums=('SKIP')
build() {
- cd "$srcdir/${_realname}-$pkgver"
- ./configure XAPIAN_CONFIG=/usr/bin/xapian-config \
- --prefix=/usr --with-php7
+ cd "${srcdir}/${_fileName}"
+ ./configure \
+ XAPIAN_CONFIG=/usr/bin/xapian-config \
+ --prefix=/usr \
+ --with-php7
make
}
package() {
- cd ${_realname}-$pkgver
+ cd ${srcdir}/${_fileName}
make DESTDIR="$pkgdir" install
}