summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
-rw-r--r--blackfire.ini2
3 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d6f9aec6e39..291b8c77be93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,4 @@
-# Generated by mksrcinfo v8
-# Mon Sep 25 14:13:16 UTC 2017
-pkgbase = php-blackfire
+pkgbase = php70-blackfire
pkgdesc = Blackfire Profiler - PHP extension
pkgver = 1.18.0
pkgrel = 1
@@ -9,13 +7,13 @@ pkgbase = php-blackfire
arch = x86_64
license = custom
depends = glibc
- backup = etc/php/conf.d/blackfire.ini
+ backup = etc/php70/conf.d/blackfire.ini
source = blackfire.ini
sha256sums = 43f82aea3877cc0133cf2278cb85d0c612cf1f6c869ad430cbaa2b2598f78f33
- source_i686 = blackfire.so-1.18.0_71_i686::http://packages.blackfire.io/binaries/blackfire-php/1.18.0/blackfire-php-linux_i386-php-71.so
- sha256sums_i686 = 4e1c31ee083d404e7c0ac3246e772469876e1d67b49152e143e5e8e5dcf7d70f
- source_x86_64 = blackfire.so-1.18.0_71_x86_64::http://packages.blackfire.io/binaries/blackfire-php/1.18.0/blackfire-php-linux_amd64-php-71.so
- sha256sums_x86_64 = d211f89afa2c75209d2b6b54d2aab2d2cd1791d63faaa15b4ee0b7652ef0e9c3
+ source_i686 = blackfire.so-1.18.0_70_i686::http://packages.blackfire.io/binaries/blackfire-php/1.18.0/blackfire-php-linux_i386-php-70.so
+ sha256sums_i686 = 9c2ab1f5efade6c37c86aad078e4c60f790a5cc97ce01067d833a0913bef1cd5
+ source_x86_64 = blackfire.so-1.18.0_70_x86_64::http://packages.blackfire.io/binaries/blackfire-php/1.18.0/blackfire-php-linux_amd64-php-70.so
+ sha256sums_x86_64 = 9d909c7d16f8b062d7dbb8eca0de95778218e227f7817511522e5120a4659fcf
-pkgname = php-blackfire
+pkgname = php70-blackfire
diff --git a/PKGBUILD b/PKGBUILD
index 173cef7b4db5..e9247e7959ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Morris Jobke <hey AT morrisjobke DOT de>
-pkgname=php-blackfire
+# Maintainer: Ha The Tung <me AT tunght DOT com>
+# Contributor: Morris Jobke <hey AT morrisjobke DOT de>
+pkgname=php70-blackfire
pkgver=1.18.0
pkgrel=1
pkgdesc='Blackfire Profiler - PHP extension'
arch=('i686' 'x86_64')
url='https://blackfire.io'
license=('custom')
-backup=('etc/php/conf.d/blackfire.ini')
+backup=('etc/php70/conf.d/blackfire.ini')
depends=('glibc')
source=('blackfire.ini')
-source_i686=("blackfire.so-${pkgver}_71_i686::http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_i386-php-71.so")
-source_x86_64=("blackfire.so-${pkgver}_71_x86_64::http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_amd64-php-71.so")
+source_i686=("blackfire.so-${pkgver}_70_i686::http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_i386-php-70.so")
+source_x86_64=("blackfire.so-${pkgver}_70_x86_64::http://packages.blackfire.io/binaries/blackfire-php/$pkgver/blackfire-php-linux_amd64-php-70.so")
sha256sums=('43f82aea3877cc0133cf2278cb85d0c612cf1f6c869ad430cbaa2b2598f78f33')
-sha256sums_i686=('4e1c31ee083d404e7c0ac3246e772469876e1d67b49152e143e5e8e5dcf7d70f')
-sha256sums_x86_64=('d211f89afa2c75209d2b6b54d2aab2d2cd1791d63faaa15b4ee0b7652ef0e9c3')
+sha256sums_i686=('9c2ab1f5efade6c37c86aad078e4c60f790a5cc97ce01067d833a0913bef1cd5')
+sha256sums_x86_64=('9d909c7d16f8b062d7dbb8eca0de95778218e227f7817511522e5120a4659fcf')
package(){
- install -Dm 644 blackfire.ini "$pkgdir"/etc/php/conf.d/blackfire.ini
- install -Dm 755 blackfire.so-${pkgver}_71_$CARCH "$pkgdir"/usr/lib/php/modules/blackfire.so
+ install -Dm 644 blackfire.ini "$pkgdir"/etc/php70/conf.d/blackfire.ini
+ install -Dm 755 blackfire.so-${pkgver}_70_$CARCH "$pkgdir"/usr/lib/php70/modules/blackfire.so
}
diff --git a/blackfire.ini b/blackfire.ini
index 44bb4df80144..07c1cb2faf78 100644
--- a/blackfire.ini
+++ b/blackfire.ini
@@ -1,5 +1,5 @@
[blackfire]
-;extension="/usr/lib/php/modules/blackfire.so"
+;extension="/usr/lib/php70/modules/blackfire.so"
blackfire.agent_socket = unix:///var/run/blackfire/agent.sock