summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
-rw-r--r--xdebug.ini5
3 files changed, 35 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42664d74f155..215c14359ab4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = php73-xdebug
- pkgdesc = PHP debugging extension
- pkgver = 3.0.4
+ pkgdesc = php73 Xdebug extension
+ pkgver = 3.1.5
pkgrel = 1
url = https://xdebug.org/
arch = x86_64
+ arch = i686
license = Xdebug
- depends = php73
- backup = etc/php73/conf.d/xdebug.ini
- source = https://xdebug.org/files/xdebug-3.0.4.tgz
- source = xdebug.ini
- sha256sums = b27290491f4634b0cd3badfc3a2be98fb1e3c0c3710a706724d8b195baad72af
- sha256sums = 7c66883dc2ade69069ef84e30188b25630748aa9c8b0dd123727c00505421205
+ makedepends = php73
+ source = http://pecl.php.net/get/xdebug-3.1.5.tgz
+ sha256sums = 55f6ef381245da079b2fc5ce1cfbcb7961197d0c0e04f9d977613cf9aa969a79
pkgname = php73-xdebug
-
+ backup =
diff --git a/PKGBUILD b/PKGBUILD
index 2c76154ba753..f8bcf7561c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,37 @@
-# Maintainer: Tomasz Gruszka <tompear79@gmail.com>
-pkgname=php73-xdebug
-pkgver=3.0.4
+ext_name=xdebug
+phpbase=73
+suffix=
+pkgname="php${phpbase}-${ext_name}${suffix}"
+pkgver=3.1.5
+source=("http://pecl.php.net/get/$ext_name-$pkgver.tgz")
pkgrel=1
-pkgdesc="PHP debugging extension"
-arch=("x86_64")
+pkgdesc="php${phpbase}${suffix} Xdebug extension"
+arch=("x86_64" "i686")
url="https://xdebug.org/"
license=('Xdebug')
-depends=("php73")
-source=("https://xdebug.org/files/xdebug-${pkgver}.tgz"
- "xdebug.ini")
-sha256sums=('b27290491f4634b0cd3badfc3a2be98fb1e3c0c3710a706724d8b195baad72af'
- '7c66883dc2ade69069ef84e30188b25630748aa9c8b0dd123727c00505421205')
-backup=("etc/php73/conf.d/xdebug.ini")
+makedepends=("php${phpbase}${suffix}")
+backup=()
build() {
- cd "${srcdir}/xdebug-${pkgver}"
- phpize73
- ./configure --prefix=/usr --enable-xdebug
- make
+ cd "${ext_name}-${pkgver}"
+ phpize${phpbase}${suffix}
+ ./configure \
+ --with-php-config=php-config${phpbase}${suffix}
+ make
}
package() {
- cd "${srcdir}/xdebug-${pkgver}"
- make INSTALL_ROOT="$pkgdir" install
- install -D -m 644 "$srcdir"/xdebug.ini "$pkgdir"/etc/php73/conf.d/xdebug.ini
+ cd "$ext_name-$pkgver"
+ _priority=40
+ ext_dir="$(php-config${phpbase}${suffix} --extension-dir)"
+ _ini_dir="/etc/php${phpbase}${suffix}/conf.d"
+ _ini_file="${_ini_dir}/${_priority}-${ext_name}.ini"
+ backup+=("${_ini_file}")
+ install -m0755 -d "${pkgdir}/${_ini_dir}"
+ echo "zend_extension=${ext_name}.so" > "${pkgdir}/${_ini_file}"
+ chmod 0644 "${pkgdir}/${_ini_file}"
+ install -m0755 -D ".libs/${ext_name}.so" "${pkgdir}/${ext_dir}/${ext_name}.so"
}
+
+sha256sums=('55f6ef381245da079b2fc5ce1cfbcb7961197d0c0e04f9d977613cf9aa969a79')
+
diff --git a/xdebug.ini b/xdebug.ini
deleted file mode 100644
index 779718ea93a9..000000000000
--- a/xdebug.ini
+++ /dev/null
@@ -1,5 +0,0 @@
-;zend_extension=xdebug.so
-;xdebug.remote_enable=on
-;xdebug.remote_host=127.0.0.1
-;xdebug.remote_port=9000
-;xdebug.remote_handler=dbgp