summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--lift-open_basedir.patch12
-rw-r--r--use-php56.patch11
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92688e6f90a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Nov 28 23:46:41 UTC 2016
+pkgbase = phpdocumentor1
+ pkgdesc = A standalone auto-documentor similar to JavaDoc written in PHP (legacy version, if you really want it)
+ pkgver = 1.4.4
+ pkgrel = 1
+ url = https://phpdoc.org/
+ arch = any
+ license = LGPL2.1
+ depends = php56
+ source = http://downloads.sourceforge.net/project/phpdocu/PhpDoc/phpDocumentor-1.4.4/PhpDocumentor-1.4.4.tgz
+ source = use-php56.patch
+ source = lift-open_basedir.patch
+ md5sums = 319243ed4e446323461f86f6fdc93149
+ md5sums = 6a7035aeea14bec2e43a445be96f422d
+ md5sums = 9ad5be0df9d5a02e3404d2fc1a34f791
+
+pkgname = phpdocumentor1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43f26b3d4ba6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=phpdocumentor1
+pkgver=1.4.4
+pkgrel=1
+pkgdesc="A standalone auto-documentor similar to JavaDoc written in PHP (legacy version, if you really want it)"
+arch=('any')
+license=('LGPL2.1')
+url='https://phpdoc.org/'
+depends=('php56')
+source=("http://downloads.sourceforge.net/project/phpdocu/PhpDoc/phpDocumentor-${pkgver}/PhpDocumentor-${pkgver}.tgz"
+ "use-php56.patch"
+ "lift-open_basedir.patch")
+md5sums=('319243ed4e446323461f86f6fdc93149'
+ '6a7035aeea14bec2e43a445be96f422d'
+ '9ad5be0df9d5a02e3404d2fc1a34f791')
+
+prepare() {
+ cd "${srcdir}/PhpDocumentor-${pkgver}"
+
+ patch -Np1 < "${srcdir}/use-php56.patch"
+ patch -Np1 < "${srcdir}/lift-open_basedir.patch"
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/share"
+ cp -a "${srcdir}/PhpDocumentor-${pkgver}" "${pkgdir}/usr/share/phpdocumentor1"
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/usr/share/phpdocumentor1/phpdoc" "${pkgdir}/usr/bin/phpdoc1"
+}
diff --git a/lift-open_basedir.patch b/lift-open_basedir.patch
new file mode 100644
index 000000000000..92cd2424fa08
--- /dev/null
+++ b/lift-open_basedir.patch
@@ -0,0 +1,12 @@
+diff -aur --no-dereference package.pristine/phpdoc package.new/phpdoc
+--- package.pristine/phpdoc 2016-11-29 00:37:36.309025526 +0100
++++ package.new/phpdoc 2016-11-29 00:41:18.460676550 +0100
+@@ -2,7 +2,7 @@
+ if [ -z "$PHP" ]; then
+ PHP=`which php`
+ fi
+-(exec $PHP -C -q -d output_buffering=1 "$0" "$@") 2>/dev/null
++(exec $PHP -C -q -d output_buffering=1 -d open_basedir= "$0" "$@") 2>/dev/null
+ if [ "$?" -ne "0" ]; then
+ echo "FAILED: Bad environment variable \$PHP (set to \"$PHP\")"
+ exit 1
diff --git a/use-php56.patch b/use-php56.patch
new file mode 100644
index 000000000000..0f42799ce11f
--- /dev/null
+++ b/use-php56.patch
@@ -0,0 +1,11 @@
+diff -aur --no-dereference package.pristine/phpdoc package.new/phpdoc
+--- package.pristine/phpdoc 2016-11-29 00:37:36.309025526 +0100
++++ package.new/phpdoc 2016-11-29 00:37:53.202230764 +0100
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ if [ -z "$PHP" ]; then
+- PHP=`which php`
++ PHP=`which php56`
+ fi
+ (exec $PHP -C -q -d output_buffering=1 "$0" "$@") 2>/dev/null
+ if [ "$?" -ne "0" ]; then