summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--LICENSE31
-rw-r--r--PKGBUILD32
-rw-r--r--phpmd.install12
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8c4ee18fff8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = phpmd
+ pkgdesc = Takes a given PHP source code base and look for several potential problems within that source.
+ pkgver = 2.1.3
+ pkgrel = 2
+ url = http://phpmd.org/
+ install = phpmd.install
+ arch = any
+ license = BSD
+ depends = php>=5.3.0
+ source = phpmd-2.1.3.phar::http://static.phpmd.org/php/2.1.3/phpmd.phar
+ source = LICENSE
+ sha1sums = a390c80f8108a07fb2d2bb91dfc175fa3a44371c
+ sha1sums = 49a94fd699270de8599423fd3302cb6880f9c224
+ sha256sums = acbc27fba706654d2a0c1358fbaf5b5a15159214aaba65904cef4faed62a78e3
+ sha256sums = faad499ee7fe2e75e18565c6b6b5cf43a3dc97a6eebffbfa5840d9205339fa9b
+
+pkgname = phpmd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6010e1b4afac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.pkg.*
+pkg/
+src/
+*.pkg.*.sig
+*.src.tar.gz
+*.phar
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..807d100a40c9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,31 @@
+Copyright (c) 2008-2014, Manuel Pichler <mapi@phpmd.org>.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ * Neither the name of Manuel Pichler nor the names of his
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
+FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
+COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..000cecc0755c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
+# Please report issues at https://github.com/jojosch/pkgbuilds
+
+pkgname="phpmd"
+pkgver=2.1.3
+pkgrel=2
+pkgdesc="Takes a given PHP source code base and look for several potential problems within that source."
+url="http://phpmd.org/"
+license="BSD"
+arch=("any")
+depends=("php>=5.3.0")
+source=(
+ "${pkgname}-${pkgver}.phar::http://static.phpmd.org/php/${pkgver}/${pkgname}.phar"
+ "LICENSE"
+)
+install="$pkgname.install"
+sha1sums=(
+ "a390c80f8108a07fb2d2bb91dfc175fa3a44371c"
+ "49a94fd699270de8599423fd3302cb6880f9c224"
+)
+sha256sums=(
+ "acbc27fba706654d2a0c1358fbaf5b5a15159214aaba65904cef4faed62a78e3"
+ "faad499ee7fe2e75e18565c6b6b5cf43a3dc97a6eebffbfa5840d9205339fa9b"
+)
+
+package() {
+ cd "${srcdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m755 "${pkgname}-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/phpmd.install b/phpmd.install
new file mode 100644
index 000000000000..72360306f81f
--- /dev/null
+++ b/phpmd.install
@@ -0,0 +1,12 @@
+post_install() {
+ if ! /usr/bin/php -i | grep Phar >/dev/null; then
+ echo
+ echo "the Phar extension of php must be enabled."
+ echo
+ echo "check if the line extension=phar.so is commented out in your php.ini"
+ echo
+ fi
+}
+post_upgrade() {
+ post_install
+} \ No newline at end of file