summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--phreeqc.el9
3 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0827cea3646b..f50da3056577 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
# Generated by mksrcinfo v8
-# Sat Feb 4 18:52:49 UTC 2017
+# Sat Apr 29 14:48:44 UTC 2017
pkgbase = phreeqc
pkgdesc = A Computer Program for Speciation, Batch-Reaction, One-Dimensional Transport, and Inverse Geochemical Calculations
- pkgver = 3.3.10
- pkgrel = 2
+ pkgver = 3.3.11
+ pkgrel = 1
url = http://wwwbrr.cr.usgs.gov/projects/GWC_coupled/phreeqc/
install = install.sh
arch = i686
arch = x86_64
license = custom
depends = gmp
- source = ftp://brrftp.cr.usgs.gov/pub/charlton/phreeqc/phreeqc-3.3.10-12220.tar.gz
+ source = ftp://brrftp.cr.usgs.gov/pub/charlton/phreeqc/phreeqc-3.3.11-12535.tar.gz
source = install.sh
source = phreeqc.el
source = https://raw.githubusercontent.com/jaalto/project-emacs--folding-mode/master/folding.el
- md5sums = c78db4331a9eaa469fcbee36e69a2101
+ md5sums = 130c6ef509c25cc35029afdfd33f4681
md5sums = 8facd6e784cd1985b2c57c092b753002
- md5sums = 9418da9a10a0927516921c407288c039
+ md5sums = 2661645b6a28535f172b2314303c400b
md5sums = d262512bd4a19a68805914d35f8f9019
pkgname = phreeqc
diff --git a/PKGBUILD b/PKGBUILD
index 4579d171706d..d927091b13c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: arch AT nnamuab DOT de
pkgname=phreeqc
-pkgver=3.3.10
-_pkgsvn=12220
-pkgrel=2
+pkgver=3.3.11
+_pkgsvn=12535
+pkgrel=1
pkgdesc="A Computer Program for Speciation, Batch-Reaction, One-Dimensional Transport, and Inverse Geochemical Calculations"
arch=('i686' 'x86_64')
url="http://wwwbrr.cr.usgs.gov/projects/GWC_coupled/phreeqc/"
@@ -23,9 +23,9 @@ source=("ftp://brrftp.cr.usgs.gov/pub/charlton/phreeqc/phreeqc-$pkgver-$_pkgsvn.
install.sh
phreeqc.el
"https://raw.githubusercontent.com/jaalto/project-emacs--folding-mode/master/folding.el")
-md5sums=('c78db4331a9eaa469fcbee36e69a2101'
+md5sums=('130c6ef509c25cc35029afdfd33f4681'
'8facd6e784cd1985b2c57c092b753002'
- '9418da9a10a0927516921c407288c039'
+ '2661645b6a28535f172b2314303c400b'
'd262512bd4a19a68805914d35f8f9019')
build() {
diff --git a/phreeqc.el b/phreeqc.el
index 0a7ec6986e73..4f80c4bf5683 100644
--- a/phreeqc.el
+++ b/phreeqc.el
@@ -57,6 +57,13 @@
:type 'string
:group 'phreeqc)
+(defcustom phreeqc-debug-buffer 0
+ "Name of the debug buffer. If 0 then process runs asychronously"
+ :type 'string
+ :group 'phreeqc)
+
+
+
(defcustom phreeqc-indent 4
"*This variable gives the indentation in Phreeqc-Mode."
:type 'integer
@@ -484,7 +491,7 @@ with no args, if that value is non-nil."
outfile "\n"
database "\n"))
- (call-process phreeqc-compile-command ctrlfile "*phreeqc*" nil)
+ (call-process phreeqc-compile-command ctrlfile phreeqc-debug-buffer nil)
(delete-file ctrlfile))))