summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85f33414e613..81bb58ff2cdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = phyml-mpi
pkgdesc = Builds phylogenies from DNA or protein sequences using a maximum likelihood approach, using multiple proccessors
- pkgver = 3.3.20200621
+ pkgver = 3.3.20211021
pkgrel = 1
epoch = 1
url = https://github.com/stephaneguindon/phyml
@@ -8,8 +8,7 @@ pkgbase = phyml-mpi
arch = x86_64
license = GPL2
depends = openmpi
- source = phyml-mpi-3.3.20200621.tar.gz::https://github.com/stephaneguindon/phyml/archive/v3.3.20200621.tar.gz
- sha256sums = a8243923ee08c74cab609a4b086ade66c6156fc2b24450e2a500108dc644c867
+ source = phyml-mpi-3.3.20211021.tar.gz::https://github.com/stephaneguindon/phyml/archive/v3.3.20211021.tar.gz
+ sha256sums = 8dd6519ccbf73ce67e57bc7681f6dffdbbc63e78e15aae79394f3ec362d42c2d
pkgname = phyml-mpi
-
diff --git a/PKGBUILD b/PKGBUILD
index 2870a57aedc2..73e64ba59a13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Mick Elliot <micke at sfu dot ca>
pkgname=phyml-mpi
-pkgver=3.3.20200621
+pkgver=3.3.20211021
pkgrel=1
epoch=1
pkgdesc='Builds phylogenies from DNA or protein sequences using a maximum likelihood approach, using multiple proccessors'
@@ -11,14 +11,20 @@ arch=('i686' 'x86_64')
url='https://github.com/stephaneguindon/phyml'
license=('GPL2')
source=("$pkgname-$pkgver.tar.gz::https://github.com/stephaneguindon/phyml/archive/v${pkgver}.tar.gz")
-sha256sums=('a8243923ee08c74cab609a4b086ade66c6156fc2b24450e2a500108dc644c867')
+sha256sums=('8dd6519ccbf73ce67e57bc7681f6dffdbbc63e78e15aae79394f3ec362d42c2d')
depends=('openmpi')
+prepare() {
+ # https://github.com/stephaneguindon/phyml/issues/156#issuecomment-949475758
+ cd "${pkgname%-mpi}-$pkgver"
+ sed -i '/^AM_INIT_AUTOMAKE$/d' configure.ac
+}
+
build() {
cd "${pkgname%-mpi}-$pkgver"
./autogen.sh
autoreconf -i
- ./configure --prefix=/usr --enable-mpi
+ ./configure --prefix=/usr --enable-phyml-mpi
make
}