summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 19 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea44348c5f40..16a52df93fc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = pianoteq-stage
pkgdesc = Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions.
- pkgver = 6.6.0
+ pkgver = 8.2.0
pkgrel = 1
url = https://www.pianoteq.com/pianoteq
- arch = i686
arch = x86_64
license = LGPL
makedepends = gendesk
- makedepends = wget
makedepends = p7zip
depends = alsa-lib
depends = freetype2
- depends = libxext
+ depends = ttf-font
+ depends = libx11
provides = pianoteq
conflicts = pianoteq
conflicts = pianoteq-stage-bin
conflicts = pianoteq-standard-trial-bin
- source = local://pianoteq_stage_linux_v660.7z
+ source = local://pianoteq_stage_linux_v820.7z
source = https://www.pianoteq.com/images/logo/pianoteq_icon_128.png
- sha512sums = cc539eed0b155a05e277dcdb3746106b5cbf8931d3b396833297a46e0485b92299b23ae091f3b4ae796caa924cc4d5b10e549a8c57d4e66a6519f64590c8217b
- sha512sums = 71690cc597b16cd363ddf8837c81eece620be275bf7860e2a2a30cc94da73f32a809d24a086c6ceacbe945282c8b73d03d6567e6058b620b4beb07feb4e46dab
+ b2sums = 92264feeb6e01bf9a0b20fc0b1265ad54532714c391ca0f4fb3db33cabbb9ccffa88fe63015a04462b40407ae51f8c7aab26a10c5d632b109c554a2a65196206
+ b2sums = bbb48b5b2bd5bbe52a39c84f42ea6c12a3633e4713e00d8132654ddf5adc5d7da1b7951c683cb11446ee847a388a775eb48591089a4e8dc69ed6d97cfc80d56d
pkgname = pianoteq-stage
-
diff --git a/PKGBUILD b/PKGBUILD
index 0723b46c6f3d..5fb27741bb14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,43 +5,38 @@
pkgname=pianoteq-stage
-pkgver=6.6.0
+pkgver=8.2.0
pkgrel=1
pkgdesc="Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://www.pianoteq.com/pianoteq"
license=('LGPL')
-depends=('alsa-lib' 'freetype2' 'libxext')
-makedepends=('gendesk' 'wget' 'p7zip')
+depends=('alsa-lib' 'freetype2' 'ttf-font' 'libx11')
+makedepends=('gendesk' 'p7zip')
optdepends=()
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}" "pianoteq-stage-bin" "pianoteq-standard-trial-bin")
# the source package must be downloaded manually
# this can be done by going to the link here:
-# https://www.pianoteq.com/download?file=pianoteq_stage_linux_v660.7z
+# https://www.modartt.com/download?file=pianoteq_stage_linux_v820.7z
source=("local://pianoteq_stage_linux_v${pkgver//./}.7z"
'https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
-sha512sums=('cc539eed0b155a05e277dcdb3746106b5cbf8931d3b396833297a46e0485b92299b23ae091f3b4ae796caa924cc4d5b10e549a8c57d4e66a6519f64590c8217b'
- '71690cc597b16cd363ddf8837c81eece620be275bf7860e2a2a30cc94da73f32a809d24a086c6ceacbe945282c8b73d03d6567e6058b620b4beb07feb4e46dab')
+b2sums=('92264feeb6e01bf9a0b20fc0b1265ad54532714c391ca0f4fb3db33cabbb9ccffa88fe63015a04462b40407ae51f8c7aab26a10c5d632b109c554a2a65196206'
+ 'bbb48b5b2bd5bbe52a39c84f42ea6c12a3633e4713e00d8132654ddf5adc5d7da1b7951c683cb11446ee847a388a775eb48591089a4e8dc69ed6d97cfc80d56d')
prepare(){
- gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='pianoteq 6' --exec='pianoteq\ 6' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='pianoteq 8' --exec='"pianoteq 8"' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
}
package(){
- _pianoteq_type="Pianoteq 6 STAGE"
- # Define architecture specific file directory:
- if [[ "$CARCH" == i686 ]]; then
- archdir=i386
- else
- archdir=amd64
- fi
+ _pianoteq_type="Pianoteq 8 STAGE"
+ archdir=x86-64bit
# Install program files:
- install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type" "$pkgdir/usr/bin/pianoteq 6"
- install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.so" "$pkgdir/usr/lib/vst/pianoteq 6.so"
+ install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type" "$pkgdir/usr/bin/pianoteq 8"
+ install -Dm 755 "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.so" "$pkgdir/usr/lib/vst/pianoteq 8.so"
cd "$srcdir/$_pianoteq_type/$archdir/$_pianoteq_type.lv2"
for i in *; do
- install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 6.lv2/$i"
+ install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 8.lv2/$i"
done
cd $srcdir
# Install desktop launcher: