summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD118
3 files changed, 81 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ab4a05a19c5..c7d94891cb6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,27 @@
pkgbase = pianoteq-standard-trial-bin
- pkgdesc = Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions.
- pkgver = 6.5.0
+ pkgdesc = Physical modelling piano instrument standalone program, VST2 and LV2 plugin. STANDARD trial version
+ pkgver = 8.2.0
pkgrel = 1
- url = https://www.pianoteq.com/home
- arch = i686
+ url = https://www.modartt.com/pianoteq
arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ groups = lv2-plugins
+ groups = pro-audio
+ groups = vst-plugins
license = custom
makedepends = gendesk
- makedepends = wget
- makedepends = p7zip
depends = alsa-lib
- depends = freetype2
- depends = libxext
+ depends = libx11
+ optdepends = jack: JACK support for stand-alone application
+ optdepends = lv2-host: for loading the LV2 plugin
+ optdepends = vst-host: for loading the VST2 plugin
provides = pianoteq-standard-trial
conflicts = pianoteq-standard-trial
- conflicts = pianoteq-standard-trial-bin
+ conflicts = pianoteq-standard-bin
+ source = local://pianoteq_linux_trial_v820.7z
source = https://www.pianoteq.com/images/logo/pianoteq_icon_128.png
+ sha256sums = 205150327f04168e57f2c519576fefb50380f37347105ad4b14fbe0af61b3757
sha256sums = 94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3
pkgname = pianoteq-standard-trial-bin
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e2bf4a7b41aa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+pianoteq_linux_trial_v*.7z
+pianoteq-standard-trial-bin-*.pkg.tar.xz
+pianoteq-standard-trial-bin-*.pkg.tar.zst
+pianoteq_icon_128.png
diff --git a/PKGBUILD b/PKGBUILD
index b965996cbde8..f2d9c373319c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,68 @@
-# Maintainer: CrocoDuck <crocoduck dot oducks at gmail dot com>
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: CrocoDuck <crocoduck dot oducks at gmail dot com>
# Contributor: Simon Thorpe <simon@hivetechnology.com.au>
pkgname=pianoteq-standard-trial-bin
-pkgver=6.5.0
+pkgver=8.2.0
pkgrel=1
-pkgdesc="Virtual piano instrument using physical modelling synthesis. Both standalone and plugin versions."
-arch=('i686' 'x86_64')
-url="https://www.pianoteq.com/home"
-license=('custom')
-depends=('alsa-lib' 'freetype2' 'libxext')
-makedepends=('gendesk' 'wget' 'p7zip')
-provides=("${pkgname%-*}")
-conflicts=("${pkgname%-*}" "pianoteq-standard-trial-bin")
-source=('https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
-sha256sums=('94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
+_name="Pianoteq ${pkgver%%.*}"
+pkgdesc='Physical modelling piano instrument standalone program, VST2 and LV2 plugin. STANDARD trial version'
+arch=(x86_64 armv7h aarch64)
+url="https://www.modartt.com/pianoteq"
+license=(custom)
+groups=(lv2-plugins pro-audio vst-plugins)
+depends=(alsa-lib libx11)
+makedepends=(gendesk)
+optdepends=(
+ 'jack: JACK support for stand-alone application'
+ 'lv2-host: for loading the LV2 plugin'
+ 'vst-host: for loading the VST2 plugin'
+)
+provides=(${pkgname%-*})
+conflicts=(${pkgname%-*} pianoteq-standard-bin)
+source=("local://pianoteq_linux_trial_v${pkgver//./}.7z"
+ 'https://www.pianoteq.com/images/logo/pianoteq_icon_128.png')
+sha256sums=('205150327f04168e57f2c519576fefb50380f37347105ad4b14fbe0af61b3757'
+ '94ee64cf6688a49d74f0bf70d811e7466abac103feeab17496a89f828afcc6d3')
-# Define the target archive filename:
-_downfname=pianoteq_linux_trial_v${pkgver//./}.7z
-# Define its checksum:
-_downsha256sum=06298d80b6db44b864f96216209bc6f3dc83106da28c930937e7d968b0879472
-
-prepare(){
- # The archive download link needs to be retrieved. Retrieve download page source:
- wget -q -O downpage.html https://www.pianoteq.com/try?file="$_downfname"
- # Now, isolate the final string of the download link from the source:
- downstr=$(cat downpage.html | grep "<form action" | grep style | grep -o -P '(?<=action=").*(?=" method)')
- # All ingredients are ready! Finalize the download url and download:
- downurl="https://www.pianoteq.com/"$downstr""
- wget --content-disposition "$downurl"
- # Check integrity:
- echo $_downsha256sum $_downfname|sha256sum -c || { echo 'Checksum failed!'; exit 1; }
- # Extract:
- 7z x $_downfname
- # Generate Desktop Entry:
- gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name='Pianoteq 6' --exec='Pianoteq\ 6' --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
+prepare() {
+ cd "$_name"
+ # Generate Desktop Entry:
+ gendesk -f -n \
+ --pkgname=${pkgname%-*} \
+ --pkgdesc="$pkgdesc" \
+ --name="$_name" \
+ --exec="\"$_name\"" \
+ --categories 'Audio;Sequencer;Midi;AudioVideoEditing;Music;AudioVideo;'
}
-package(){
- # Define architecture specific file directory:
- if [[ "$CARCH" == i686 ]]; then
- archdir=i386
- else
- archdir=amd64
- fi
- # Install program files:
- install -Dm 755 "$srcdir/Pianoteq 6/$archdir/Pianoteq 6" "$pkgdir/usr/bin/Pianoteq 6"
- install -Dm 755 "$srcdir/Pianoteq 6/$archdir/Pianoteq 6.so" "$pkgdir/usr/lib/vst/Pianoteq 6.so"
- cd "$srcdir/Pianoteq 6/$archdir/Pianoteq 6.lv2"
- for i in *; do
- install -D "$i" "$pkgdir/usr/lib/lv2/Pianoteq 6.lv2/$i"
- done
- cd $srcdir
- # Install desktop launcher:
- install -Dm 644 "$srcdir/pianoteq_icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -Dm 644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/${pkgname%-*}.desktop"
- # Install the license:
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- install -m 644 Pianoteq\ 6/*Licence* "$pkgdir/usr/share/licenses/$pkgname/"
- # Install the Documentation:
- install -D "Pianoteq 6/README_LINUX.txt" "$pkgdir/usr/share/doc/${pkgname%-*}/README_LINUX.txt"
- cd "$srcdir/Pianoteq 6/Documentation"
- for i in *; do
- install -D "$i" "$pkgdir/usr/share/doc/${pkgname%-*}/$i"
- done
+package() {
+ cd "$_name"
+
+ # Define architecture specific directory:
+ if [[ "$CARCH" == x86_64 ]]; then
+ _archdir=x86-64bit
+ elif [[ "$CARCH" == armv7h ]]; then
+ _archdir=arm-32bit
+ elif [[ "$CARCH" == aarch64 ]]; then
+ _archdir=arm-64bit
+ fi
+
+ # Install executables and plugins:
+ install -Dm 755 "$_archdir/$_name" -t "$pkgdir"/usr/bin
+ ln -sf "$_name" "$pkgdir"/usr/bin/${pkgname%-bin}-${pkgver%%.*}
+ install -Dm 755 "$_archdir/$_name.so" -t "$pkgdir"/usr/lib/vst
+ install -Dm 755 "$_archdir/$_name.lv2"/*.so -t "$pkgdir/usr/lib/lv2/$_name.lv2"
+ install -Dm 644 "$_archdir/$_name.lv2"/*.ttl -t "$pkgdir/usr/lib/lv2/$_name.lv2"
+
+ # Install desktop launcher:
+ install -Dm 644 "$srcdir"/pianoteq_icon_128.png \
+ "$pkgdir"/usr/share/pixmaps/${pkgname%-*}.png
+ install -Dm 644 ${pkgname%-*}.desktop -t "$pkgdir"/usr/share/applications
+
+ # Install the license:
+ install -Dm 644 *Licence* -t "$pkgdir"/usr/share/licenses/$pkgname
+
+ # Install the Documentation:
+ install -Dm 644 README_LINUX.txt Documentation/* -t "$pkgdir"/usr/share/doc/$pkgname
}