summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rwxr-xr-xmkAsm14
3 files changed, 20 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f73259071ba0..eafb0648031b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = picolisp
pkgdesc = Fast and tiny 64-bit Lisp interpreter: OO, dynamic and functional (database, prolog, coroutines).
- pkgver = 16.2.r0.g0b67511
+ pkgver = 16.6.r0.g03016a6
pkgrel = 1
url = http://www.picolisp.com
install = picolisp.install
diff --git a/PKGBUILD b/PKGBUILD
index 785608242e86..ac3d8be369fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: taij33n <bwbuiz@gmail.com>
pkgname=picolisp
-pkgver=16.2.r0.g0b67511
+pkgver=16.6.r0.g03016a6
pkgrel=1
pkgdesc="Fast and tiny 64-bit Lisp interpreter: OO, dynamic and functional (database, prolog, coroutines)."
url="http://www.picolisp.com"
@@ -18,6 +18,10 @@ pkgver() {
# cutting off 'foo-' prefix that presents in the git tag
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${srcdir}/${pkgname}/src64"
+ cp -f ../../../mkAsm ./
+}
build() {
# build 32bit version and tools first
diff --git a/mkAsm b/mkAsm
new file mode 100755
index 000000000000..bca250c8c608
--- /dev/null
+++ b/mkAsm
@@ -0,0 +1,14 @@
+#!/bin/sh
+# 05sep16taijeen
+
+if test -x ../bin/picolisp
+then
+ ../bin/picolisp ../lib.l ../lib/misc.l ../lib/btree.l ../lib/db.l ../lib/pilog.l mkAsm.l "$@"
+elif test -x /usr/bin/picolisp
+then
+ /usr/bin/pil mkAsm.l "$@"
+else
+ ../ersatz/pil mkAsm.l "$@"
+fi
+
+# vi:et:ts=3:sw=3