summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8158beee6be1..694ed8bb3f15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur
- pkgdesc = AUR helper with minimal dependencies. Review PKGBUILDs all in once, next build them all with minimal user interaction.
- pkgver = 0.9.3
+ pkgdesc = AUR helper with minimal dependencies. Review PKGBUILDs all in once, next build them all without user interaction.
+ pkgver = 0.10
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
@@ -8,11 +8,10 @@ pkgbase = pikaur
depends = pyalpm
depends = python-setuptools
depends = git
- depends = sudo
depends = fakeroot
conflicts = pikaur-git
- source = pikaur-0.9.3.tar.gz::https://github.com/actionless/pikaur/archive/0.9.3.tar.gz
- md5sums = 50a5f35e909f8b798d4fc2f945a9fd3a
+ source = pikaur-0.10.tar.gz::https://github.com/actionless/pikaur/archive/0.10.tar.gz
+ md5sums = 854d12b6a9a92fc94b34ace6dceed93f
pkgname = pikaur
diff --git a/PKGBUILD b/PKGBUILD
index ea8885d07d38..e059a1a48b90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,20 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=0.9.3
+pkgver=0.10
pkgrel=1
-pkgdesc="AUR helper with minimal dependencies. Review PKGBUILDs all in once, next build them all with minimal user interaction."
+pkgdesc="AUR helper with minimal dependencies. Review PKGBUILDs all in once, next build them all without user interaction."
arch=('any')
url="https://github.com/actionless/pikaur"
license=('GPLv3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('50a5f35e909f8b798d4fc2f945a9fd3a')
+md5sums=('854d12b6a9a92fc94b34ace6dceed93f')
depends=(
'pyalpm'
'python-setuptools'
'git'
- 'sudo'
'fakeroot'
)
conflicts=('pikaur-git')
@@ -30,7 +29,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
- for lang in fr ru pt de; do
+ for lang in fr ru pt de is; do
install -Dm644 "locale/${lang}.mo" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"
done
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"